Installation problem : OpenVPN Client Export Utility



  • i am getting an error while trying to install the package : "OpenVPN Client Export Utility"
    below you'll find the error returned for GUI and Shell.

    how can i resolve this issue ?
    the Firewall have access to Internet, i've also changed the DNS server in vain.

    i am using the 2.2.4-RELEASE (amd64)

    Thanks

    Installation from GUI :

    Installation of OpenVPN Client Export Utility FAILED!


    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi ...  could not download from there or https://files.pfsense.org/packages/10/All//zip-3.0_1-amd64.pbi.
    of zip-3.0_1-amd64.pbi p7zip-9.20.1_2-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for zip-3.0_1-amd64...done.
    Starting package deletion for p7zip-9.20.1_2-amd64...done.
    Removing OpenVPN Client Export Utility components...
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.


    installation from Shell :

    [2.2.4-RELEASE][root@FW1]/root: pfSsh.php playback listpkg

    Starting the pfSense developer shell….

    Installed packages:

    Warning: Invalid argument supplied for foreach() in /usr/local/sbin/pfSsh.php(331) : eval()'d code on line 11
    [2.2.4-RELEASE][root@FW1]/root:

    [2.2.4-RELEASE][root@FW1]/root: pfSsh.php playback installpkg "OpenVPN Client Export Utility"

    Starting the pfSense developer shell….

    Installing package "OpenVPN Client Export Utility"...
    Trying to fetch package info... Done.

    Beginning package installation for OpenVPN Client Export Utility .
    Installing OpenVPN Client Export Utility and its dependencies.ERROR: can't find installed pbi (zip-3.0_1-amd64)
    ERROR: can't find installed pbi (p7zip-9.20.1_2-amd64)

    Done.
    [2.2.4-RELEASE][root@FW1]/root: ping files.pfsense.org
    PING files.pfsense.org (162.208.119.39): 56 data bytes
    64 bytes from 162.208.119.39: icmp_seq=0 ttl=47 time=120.275 ms
    64 bytes from 162.208.119.39: icmp_seq=1 ttl=47 time=119.606 ms
    64 bytes from 162.208.119.39: icmp_seq=2 ttl=47 time=119.718 ms
    ^C
    –- files.pfsense.org ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 119.606/119.866/120.275/0.293 ms
    [2.2.4-RELEASE][root@FW1]/root:



  • Clearly says  that pbi download failed. Check your connection to files.pfsense.org.



  • Thanks for the answer

    do i have to open some ports, add rules into PfSense itself ?

    i am asking cause i gave a PC an IP address in the same network of the WAN interface of PfSense.
    the PC have total access to the internet

    also, in my border router/firewall i am NATing and Opening the whole network listed above for Internet

    so PfSense access Internet from its WAN interface address ? or i have to open Internet for another interface rather than the WAN one ?

    Thanks


  • Banned

    Simply stop blocking access to packages.pfsense.org. No idea about your border routers or whatever.



  • the problem was from DNS
    even if i've configured three valid DNS servers, and even if i can ping FQDN from shell and also the FQDN are resolved via the GUI Diagnostics - DNS Lookup, the package wont be installed

    finally when i checked the option below, all went well, and the package is installed :

    system - general setup - Do not use the DNS Forwarder or Resolver as a DNS server for the firewall

    it's really weird, why PfSense list available package in  System: Package Manager - Available Packages, and it cannot download the package ?

    why ? i am asking the question cause PfSense must have Internet connection to list available package, this mean that PfSense must also have valid DNS servers

    in my actual case, PfSense use the DNS servers to list available packages, and doesn't use them while trying to install packages, it's really weird behaviour.

    anyway, it was a great lesson …..



  • @boujid:

    the problem was from DNS
    even if i've configured three valid DNS servers, and even if i can ping FQDN from shell and also the FQDN are resolved via the GUI Diagnostics - DNS Lookup, the package wont be installed

    finally when i checked the option below, all went well, and the package is installed :

    system - general setup - Do not use the DNS Forwarder or Resolver as a DNS server for the firewall

    it's really weird, why PfSense list available package in  System: Package Manager - Available Packages, and it cannot download the package ?

    why ? i am asking the question cause PfSense must have Internet connection to list available package, this mean that PfSense must also have valid DNS servers

    in my actual case, PfSense use the DNS servers to list available packages, and doesn't use them while trying to install packages, it's really weird behaviour.

    anyway, it was a great lesson …..

    The solution mentioned at the link above is only half of the solution. There are 2 check boxes on the mentioned pfSense 2.2.4 configuration page. The first one needs to be off/disabled, the second one needs to be on/enabled. After I did that, I was able to install packages.

    The 1st checkbox in this case is called: Allow DNS server list to be overridden by DHCP/PPP on WAN
    The 2nd checkbox in this case is called: Do not use the DNS Forwarder or Resolver as a DNS server for the firewall


  • LAYER 8 Global Moderator

    I have neither of those set and just use the resolver in pfsense for all my dns, both for pfsense itself and clients on my network..  And have no problems downloading packages..


Log in to reply