On boot getting stuck at "Starting DNS Resolver"



  • Hey,

    We are trying to implement pfsense in our virtual environment (esx 5.5) but upon boot the vm is getting stuck at Starting DNS Resolver, i have let it run for 45 minutes without luck.

    The only way around this is to unbind the NICs until it gets to the main admin screen and then re-connecting them.

    So far i have tried:

    • Reconnecting NICs after boot

    • Rebuilding from scratch

    • Changing VM version to 8

    After it eventually boots it's unstable at best and im not confident deploying for our site. We're running 2.2.4-RELEASE x64.

    http://imgur.com/B4D34PX



  • Odd, not something I've heard of before. Not sure what could cause it to hang there that wouldn't be an issue if the NICs were disconnected. I'd put another VM on the vswitch where the firewall's default gateway resides, on a port group with promiscuous enabled, and capture the VM's traffic to see what it's trying to do. What's in the DNS Resolver log once you're booted up?



  • It seems we are having the same issue. With the SG device. We tried installing 2.2.3 and 2.2.4 with no luck. We did try removing the Ethernet cables during boot and startup was quick. Though it is not acceptable solution.


  • Rebel Alliance Developer Netgate

    Have you tried disabling DNSSSEC or enabling forwarding mode (or both?)



  • This post is deleted!


  • try this...
    cmd > ipconfig /flushdns
    cmd > ipconfig /registerdns


  • Netgate Administrator

    Please don't reply to ancient threads unless there is a very good reason to. Locking this.

    Also those Windows/DOS commands would not help in the described pfSense DNS issue.

    Steve


Locked