Can't change interface configuration after restoring config.xml



  • Had a working config on 2.1.5 that I am trying to restore to different hardware.

    After fresh install of 2.2.4 (memstick amd64 vga) + restore from webGUI + reboot, looking at console output and webGUI front page the configuration seems to be there.

    Issue is, if I click on any interface name from the "(assign)" menu, the only, single, option I see for any interface is "enable" (checked).  Also, if I assign interfaces to different network ports, the "Save" button doesn't show up.

    I have tried reinstalling 2.1.5 and restoring and the effect is the same.  I have checked in the fresh install, after going through the installation wizard, that the default interfaces can be edited and remapped.  It is only after restoring config.xml that the rest of the interface configuration options and the "Save" button for assigning disappear.

    The config.xml file is from different hardware: I had a system based on a Jetway NF9I-2550 motherboard with the 4 Intel NIC daughtercard and an Atheros AR5BXB72 5418 mini-pcie card that died an overheating death: box woke up one morning extremely hot with lots of errors in the log and did not came back after a reboot. I got a completely new system based on a Jetway NF9N-2930, same daughtercard (new one), and an Ubiquity SR71-E mini-pcie card.

    As far as I can tell the config works I can get to the webGUI from the port on the LAN which I have setup to 192.168.22.0/24, with a different access port to the webGUI than the default, so I can tell the new config is in place. Wifi also works from the SR71-E (same ath0 port/driver). I haven't tried the WAN.

    Without the rest of the configuration options showing up I can't make any change. I noticed because I wanted to change the wifi SSID.

    Any help much appreciated. I am back to the Verizon FIOS stock router equipment, and (aside from not being able to access half of my small lab at home in a VLAN) I feel TOTALLY lame.

    -Cristian



  • Before you restore the config.xml, you need to edit it directly to alter the NIC information to match the new hardware. If you're unsure, do a fresh install and have a look at the NIC info in the new config. You can use that information to amend the content of your backed up config before restoring.



  • Before you restore the config.xml, you need to edit it directly to alter the NIC information

    I have done that, the config file I am trying to restore has those edits done.

    The hardware is almost the same, the main difference is, the motherboard NIC in the new box is igb0 instead of em0.

    I also tried restoring the same file, and I got asked in the console for remapping the interfaces, as expected. The result in both cases is the same, in the webGUI no configuration options are shown for any interfaces, other than "Enable".

    -Cristian



  • This message has attached 3 screenshots from the webGUI in trying to make things more visual.

    (1) Interfaces-assign.png show the Interfaces -> (assign) page as initially displayed after login in.
    (2) Interfaces-assign-changed-lan22-no-save-button.png shows the effect of clicking on the pulldown for "LAN22"
        (opt1) and changing the mapping from em2 to em1. Note no Save button after doing that.
    (3) Interfaces-lan22-only-option-enable.png show the effect of clicking on "LAN22". Only one section displayed,
        "General Configuration". Only one option displayed, "Enable".

    All interfaces look the same as (3) when clicked. Single option displayed, "Enable".

    -Cristian








  • Have you tried removing an interface and re-adding it? What about re-creating the interfaces on a fresh install and then just selectively restoring the rest of the config, ignoring the interface part?



  • Solved.  The problem had nothing to do with pfsense.  I was running firefox with NoScript activated, which somehow interfered.  Enabling scripts globally (in NoScript - Firefox, the browser) fixed the issue, which apparently was only rendering.  NoScript typically gives a warning when its tinkering with a page, so that you get a chance to disable it for that page.  In this case it was silent, which is weird.

    -Cristian


  • Banned

    Extremely surprising that NoScript breaks things. One of the most harmful pieces of browser "extension" crap ever written.


Log in to reply