DHCP Server uses wrong Router address



  • Hi Guys.

    I have stuck PFSence on an old PC and so far it seems very good. I am however having a problem. I initially set it up with an IP of 192.168.0.4 just whilst I set it up, knowing my current router is on 192.169.0.1

    Set up went well so I pulled the old router and changed the IP addy on PFSense to 192.168.0.1

    However on any DHCP devices on the network, its given a correct DHCP address but it believes the router is at 192.168.0.4, I can find no settings anywhere that recover this situation so I am a bit stuck as I have 20 odd devices with fixed IPs correctly resolving to 192.168.0.1 and everything else unable to connect to the internet.

    Could someone give ma a hint as to what to do? I can successfully get to the GUI on 192.168.0.1 so am baffled as to why its telling everything its on 4



  • Sorry forgot to say everything that has a fixed IP to 192.168.0.1 connects correctly even though I set it back to 192.168.0.4

    Also if I cahnge fixed IPs to pick up on 4, it no longer connects.

    Its a real mess!


  • LAYER 8 Global Moderator

    Did you think to reboot it after changing its IP, or did you restart the dhcp server?



  • Hello, yes sorry I did not restart it which I have now done. Its all working fine now :)

    I am struggling a little bit with VPN, I used pptp on my asus router which worked well as I was able to tell it to use a dyn account for access as my IP is dynamic. I cannot see how to do this on any of the options in PFSense, could you give me a hint?

    I have successfully set up the dynamic DNS.


  • LAYER 8 Global Moderator

    in the openvpn client export (package) just click the dropdown and pick your dyn setup.  Or just select other and put whatever you want in there IP, fqdn

    Sure hope your not trying to use pptp that has been deprecated for YEARS!!






  • Thank you for your help I will give it a try.

    I do appreciate that there are warnings with pptp but it was easy to set up. I tried things like openvpn, you get so far then find that money is required or, some other un-utterable confusion.

    OK I have managed to set up my own router so I am not a complete numpty, but VPN instructions are like swimming in syrup most of the time!

    BTW its ridiculous how quick my network is with this software on a PC. I don't cheap it with routers, usually electing for the latest Asus what ever each year, but this just knocks it about. I am very impressed, plus its totally stealth according to port scans. Happy days!


  • Banned

    PPTP is completely removed from 2.3, seriously - avoid starting with dead end roads on newly setup systems. Complete waste of time



  • Yea I get it, not that one.

    I have a mac for on the move the choices are: L2TP over IPSec, PPtp, Cisco IPSec or IKEv2

    none of these really match the choice in PFSense. I have prodded for a couple of hours this evening but cannot get a VPN connection, its quite difficult, the language in use. Is a pre shared key a password? (for instance)





  • Thanks Heper.

    Where I come unstuck is I put my dyn account as the address, when I click save it complains its not a valid IP. In the IPSec settings where am I telling it to use DYN not an IPaddress?


  • LAYER 8 Global Moderator

    There is no cost for openvpn.. I use a free client on my ipad and iphone https://itunes.apple.com/us/app/openvpn-connect/id590379981?mt=8 , you can download the free client from openvpn for windows or linux.  And pretty sure that same connect client is for android as well.

    I even run the access server version on my vpses, which is free for 2 concurrent connections which is all I need for home use..  This allows me to have a vpn I can access even if my home internet connection is down, etc.

    If your talking about the mac client vicosity – its what 9$ https://www.sparklabs.com/viscosity/

    For free there is tunnelbrick https://tunnelblick.net/ and they have instructions on its use on openvpn
    https://openvpn.net/index.php/access-server/docs/admin-guides/183-how-to-connect-to-access-server-from-a-mac.html

    You do understand that ipsec requires ports and protocols be open where your at, which is not always the case.  But if your run your openvpn connection on tcp 443 or atleast 1 of the instances on that.. Your pretty much guaranteed that if there is internet where you at on the road that you can get to your vpn.. It even bounces off proxies -- can you do that with ipsec or pptp.

    Not sure what your issue is with your dyn - why don't you pm me your fqdn your trying to use and I will tell you if it resolves or not on the public net.  And if so to what.

    Your best option is openvpn is hands down..  Not having a native client in your OS of choice is just a lame excuse with no real foot to stand on..



  • OK I'll give open vpn another shot. I tried it a long while ago, with tunnelblick and it was not a success.



  • Thanks for everyones help, in the end I managed to get OpenVPN sorted, at least on my mac and phone. On the PC Laptop it connects fine but I cannot connect to any of my mapped network drives, but I rarely use the PC any way so can live with that.

    Man doing the OPenVPN was harder than creating a router lol.


  • LAYER 8 Global Moderator

    not sure what you consider hard.. if it took you more than 60 seconds you were doing something wrong ;)

    Run through the wizard, download the config file = done..  Really is brainless clickity clickity.

    I access file shares on my home network from on the road vpn'd in all the time

    C:>net view \storage.local.lan
    Shared resources at \storage.local.lan

    Share name  Type  Used as  Comment
    –-----------------------------------------------------------------------------
    backup      Disk
    Media      Disk
    Molly      Disk
    Music      Disk
    public      Disk
    The command completed successfully.

    C:>net use * \storage.local.lan\backup
    Drive Y: is now connected to \storage.local.lan\backup.

    The command completed successfully.

    C:>y:

    Y:>dir
    Volume in drive Y is rdm2-backups
    Volume Serial Number is 3E65-EE10

    Directory of Y:
    09/06/2015  10:01 AM

    <dir>          backup-molly
                  0 File(s)              0 bytes
                  1 Dir(s)  627,172,126,720 bytes free

    Y:>

    So not sure where your having a hard time??</dir>



  • Well where I am having a hard time is the way you randomly mashed the keyboard there (as far as I know :) )

    I do understand that making your own router is somewhat geeky and therefore the assumption is I have half a clue, I hope that this thread has served to ruin that assumption.

    I have no idea why the PC won't connect to shares, on the mac it does it just fine, as I said, enough messing now, it works for the mac and phone, good enough. I have an awesome 4 tonne dell work station laptop, but its windows and dell, so I rarely use it.



  • @johnpoz:

    If your talking about the mac client vicosity – its what 9$ https://www.sparklabs.com/viscosity/

    +! for this client on the Mac.  I use it all the time with excellent results.  Connects quickly, has a menu icon to tell you when it's connected, very small footprint and imports OpenVPN client exports like a champ.  Very Mac-friendly.

    I recommend this client to all my Mac customers as well as my PC customers.  It just works.


Log in to reply