ISP uses captive portal



  • My ISP uses captive portal to logon.  The wan connections gets a 109.x.x.x IP address with a gateway and a DNS server.

    My lan network is 192.168.1.1/24 and the dns server is 192.168.1.1

    On my computer when I first connect, I get a 192.168.1.2 IP address and a 192.168.1.1 DNS server. Normally when I open the browser, it should redirect the page to the captive portal page that my ISP uses on 109.x.x.x.

    But it doesn't, it just says page can't resolve. If I set the DNS on my computer manually to the ISP dns 109.x.x.x then it will do the redirection.

    DNS resolver in pfsense is enabled. What am I missing?



  • dns resolver is enabled …. thats what you are missing =)

    Enable Forwarding Mode: Controls whether Unbound will query root servers directly (unchecked, disabled) or if queries will be forwarded to the upstream DNS servers defined under System > General or those obtained by DHCP/PPPoE/etc (checked, enabled). Forwarding mode may be enabled if the upstream DNS servers are trusted and also provide DNSSEC support. Forwarding mode is necessary for Multi-WAN Configurations.



  • The pfsense docs says in 2.2 dns forwarding has been replaced by dns resolver.

    I got it to work in dns resolver. I have to untick "Enable DNSSEC Support"

    This was stopping the redirection.

    Thanks!



  • that could be it too.

    captiveportal redirects tend to mess with dns … dnssec tries to prevent messing with dns ;)


Log in to reply