L2TP connection setup. Have commands for Router OS 4



  • The ISP I am dealing with now wants me to run commands on a Mikrotik router using routerOs L4.

    I figure pfsense can handle whatever shit, so i tried to configure what i believe to be a L2TP connection. Tried a few different ways, but i am having issues translating the commands into things i can do on pfsense. Commands located below, plus what i think is trying to happen. Please tell me why it does not work.

    /interface bridge add name=Lan
    /interface bridge port add interface=ether2 bridge=Lan
    /interface bridge port add interface=ether3 bridge=Lan
    /interface bridge port add interface=ether4 bridge=Lan
    /interface bridge port add interface=ether5 bridge=Lan
    
    

    Bridge all the lan ports together and give them the name LAN. (This is not a step i am doing on the local pfsense currently, why may be why i am having the problem). I think when you make an l2tp connection it already makes a second virtual interface (ltp0 or something like that)?

    /ip dhcp-client add interface=ether1 add-default-route=no disabled=no
    /ip route add dst-address=PUBLIC_IP_ADDRESS/32 gateway=ether1
    
    

    Make the first port into a DHCP client (WAN i assume). Route packets to PUBLIC_IP_ADDRESS (I assume this is a RADIUS server or similar). Gateway is itself, wan gateway but dynamically assigned.

    
    /ip address add address=GATEWAY_IP_ADDRESS/30 interface=Lan disabled=no
    /interface l2tp-client add name=VPN user=USERNAME password=PASSWORD connect-to=PUBLIC_IP_ADDRESS add-default-route=yes profile=default disabled=no
    

    GATEWAY_IP_ADDRESS = what the isp told me the gateway would be. One minus my static IP. Apply that IP address to the interface bridge lan. Make it an L2TP client with credentials and the same PUBLIC_IP_ADDRESS that would presumably do the authentication.

    So I think what they want is:  WAN PORT (dhcp client?) -> LAN PORTS (gateway?) -> Pfsense (with what i would assume is the static IP).

    I tried to configure a few times. Here are some errors from the log that i have received:

    php-fpm[35880]: /rc.filter_configure_sync: Could not find IPv4 gateway for interface (wan).

    ppp: L2TP: Control connection 0x29050908 terminated: 6 (expecting reply; none received)

    I have set the WAN port to l2tp and put in the credentials and default gateway (PUBLIC_IP_ADDRESS/32). Setting the local to the GATEWAY_IP_ADDRESS/30 and a static route on gateway of PUBLIC_IP_ADDRESS/32.

    I have set the WAN port to DHCP and enabled a seperate ppp connection l2tp and attempted various ways to bind the two together.

    If anyone knows the correct way to do this, let me know. Thanks! I hate buying unnecessary things if what i got can do the job!


Log in to reply