Uploads stalling



  • Hi. I'm Tiny, new to the forums and seem to be experiencing a problem noone, or few others, has.

    I have a fresh installation of pfSense 2.2.4-RELEASE (i386) running in a libvirt VM and bridged network-interfaces to allow access to both internal lan and external wan (each is physical nic, no vlan-magic). Most things run well. Downloads and uploads are in very high speeds, until I try to upload something bigger than 2mb per connection. Download is no problem at all, speedtest shows some of the highest speeds I've tested from this location. The upload-test doesn't even connect. I can browse the web just fine and download anything without a problem. But any upload above 2mb stalls.

    Nothing except an out-of-the-box pfSense installation is on the machine.

    Best regards
    Tiny

    Edit:
    Additional information: Moving large files from the VM itself is no problem.



  • i386 is a dead-end so you should be using amd64 if possible.

    pfSense out of the box has no problems with speedtest.net that I've ever seen.  I run virtual but under VMware ESXi.  Do you have any extra packages installed?  Some kind of funky network topology?



  • Unfortunately I messed up when installing my main server last time and it is running i386. I'm stuck on that until I can get some new hardware and be able to do a migration.

    I have only installed freeradius3, though I haven't configured it and it shouldn't affect network speeds and connectivity.

    I have a bit of a funky network topology, though nothing really spectacular:

    I have 10/10 from my ISP limited by IP so I have set up a second router to let my servers go through so I game play my games and whatnot undisturbed. Most devices on my LAN have a static configuration and then I have a DHCP with small pool for guests and temporary devices.

    Any ideas? Id be willing to sacrifice a small computer to the elders of the internet if it helps?




  • As a test, bypass the switch and other routers, and just connect your pfSense to WAN and LAN directly, then try your test again.  Rule out the easy stuff first.



  • No change.



  • Must be something about libvert or its virtual NIC.  pfSense has no problems with speedtest.



  • Ok

    I'll try to remember this thread for when I've installed 64-bit and know if there's a difference

    Thanks for the help :)



  • I run pfSense 2.2.4 under VMware ESXi 6.0.  I just did a quick test and got 94 Mbps down and 78 Mbps up on my 100/100 link.



  • Hello again

    I just installed 32-bit pfSense on a physical machine and as expected it ran just fine.

    Someday I might revisit this issue and see if I can find a working libvirt configuration, but for now this works.


Log in to reply