Sarg + SquidGuard-squid3 | pfSense 2.1.5 ERRO!



  • Caros colegas,

    Meu cenário:

    pfSense 2.1.5-RELEASE (amd64) FreeBSD 8.3-RELEASE-p16

    squid3-dev 3.3.10 pkg 2.3.0

    squidGuard-squid3 1.4_4 pkg v.1.9.12

    Sarg 2.3.6_2 pkg v.0.6.6

    Optei por utilizar o squidguard como proxy server nas configurações do Sarg e ao clicar em View Report, obtenho o bendito erro:

    Error: Could not find report index file.
    Check and save Sarg settings and try to force Sarg schedule.

    e executando o comando sarg -x no terminal o Sarg retorna o seguinte erro:

    SARG: Cannot open squidGuard config file: /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf

    Pois bem, se eu altero a opção de squidguard para squid em proxy server no Sarg funciona e o relatório e gerado com sucesso, levando-se em consideração que já realizei o procedimento disponibilizado nesse post aqui do fórum: https://forum.pfsense.org/index.php?topic=89485.0

    Por favor alguém já possou pelo mesmo problema e pode me dar uma ajuda?

    Abs.



  • Pessoal boa tarde,

    Consegui resolver o problema alterando no sarg.conf (/usr/pbi/sarg-amd64/etc/sarg/sarg.conf) o caminho onde aponta o squidGuard.conf.

    Lá estava assim:

    TAG: squidguard_conf file

    #      path to squidGuard.conf file
    #      Generate reports from SquidGuard logs.
    #      Use 'none' to disable.
    #      You can use sarg -L filename to use an alternate squidGuard log.
    #      squidguard_conf /usr/local/squidGuard/squidGuard.conf

    squidguard_conf /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf

    Alterei então para o caminho onde de fato está o squidGuard.conf:

    /usr/pbi/squid-amd64/etc/squid/squidGuard.conf

    P.S. Utilizei o pacote Filer para realizar essa modificação.

    Obrigado!



  • Correção:

    Resolvi o problema parcialmente, com o procedimento anterior ao executar o comando sarg -x no terminal o arquivo sarg.conf volta ao original, ou seja, a modificação não prevalece.  :-[

    Realizei outro procedimento que eliminou o erro " SARG: Cannot open squidGuard config file: /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf " que foi o link simbólico com o comando:

    ln -s /usr/pbi/squid-amd64/etc/squid /usr/pbi/squidguard-squid3-amd64/etc/squidGuard

    O problema agora é que o relatório Redirector só apareceu uma vez e desde então ao forçar os agendamentos ele não apareceu mais.

    Enfim, continuo na saga para tentar solucionar esse problema…

    Se alguém puder me dar uma força eu agradeço....



  • @allanbbg:

    Lá estava assim:

    TAG: squidguard_conf file

    #      path to squidGuard.conf file
    #      Generate reports from SquidGuard logs.
    #      Use 'none' to disable.
    #      You can use sarg -L filename to use an alternate squidGuard log.
    #      squidguard_conf /usr/local/squidGuard/squidGuard.conf

    squidguard_conf /usr/pbi/squidguard-squid3-amd64/etc/squidGuard/squidGuard.conf

    Alterei então para o caminho onde de fato está o squidGuard.conf:

    /usr/pbi/squid-amd64/etc/squid/squidGuard.conf

    P.S. Utilizei o pacote Filer para realizar essa modificação.

    Obrigado!

    allanbbg,

    você já tentou alterar o arquivo via  Diagnosis > Edit File ? Estava com um problema bem parecido e resolvi com a sua dica. Além disso, sempre uso essa função do pfsense para pequenas alterações em arquivos.

    Obrigado.



  • Olá Galera,

    Obrigado.. consegui resolver meu problema com essa dica! Agora os relatórios do Squidguard no SARG são gerados com sucesso..
      :)

    Acessei diagnostics edit file localizei o arquivo (/usr/pbi/sarg-amd64/etc/sarg/sarg.conf)  e nele adicionei na parte que estava somente SquidGuard o restante do caminho ficando dessa forma.

    TAG: squidguard_conf file

    #      path to squidGuard.conf file
    #      Generate reports from SquidGuard logs.
    #      Use 'none' to disable.
    #      You can use sarg -L filename to use an alternate squidGuard log.
    #      squidguard_conf /usr/local/squidGuard/squidGuard.conf

    squidguard_conf /usr/pbi/squid-amd64/etc/squid/squidGuard.conf

    Abraços

    Diego


Log in to reply