Saving WAN connection restores connection?



  • Having an intermittent problem with my Comcast WAN connection.

    Every 1-3 days I lose the Comcast connection on the WAN interface and a sure fix is to click on the Save button on the WAN interface page.  I suspect it restarts a service and clears something…

    I'd like to diagnose the problem so I'm asking for advice about what I should be looking at.

    Thoughts?

    Thanks,
    Chris.

    2.2.4-RELEASE (i386)
    built on Sat Jul 25 19:56:41 CDT 2015
    FreeBSD 10.1-RELEASE-p15
    Unable to check for updates.

    CPU Type
    Intel Pentium III

    State table size
    2% (413/22000)

    MBUF Usage
    9% (1266/14222)

    CPU usage
    1%

    Memory usage
    27% of 222 MB

    SWAP usage
    0% of 512 MB

    Disk usage
    / (ufs): 2% of 36G
    /var/run (ufs in RAM): 3% of 3.4M



  • "Lose connection":  physical link drops, lose the IP address?  Is WAN port plugged directly into the cable modem or is there something in between?  It would probably be helpful to see screenshots of WAN interface configuration.  It should probably be DHCP, so there should be information in logs somewhere about lease time.  Whatever your pfSense WAN is plugged into, is that your equipment or is it Comcast owned?



  • Every 1-3 days I lose the Comcast connection on the WAN interface and a sure fix is to click on the Save button on the WAN interface page.

    Clicking "save" and then "apply" you mean, or?

    If the comcast ISP is giving you a real and pure modem, something is perhaps wrong at the
    pfSense WAN set up.

    If the comcast ISP is giving you a real router doing also NAT likes your pfSense it could be more pointed
    to the "device" in front of the WAN port of the pfSense. Because then you have created a double NAT or
    so called router cascade doing double NAT!

    Some more informations from you about this set up would be fine.



  • Thanks for the replies, BlueKobold, mer.

    Yes.  Save and Apply. 
    Yes.  DHCP

    The cable-modem is stock issue from Comcast; Arris TM722 - the connection goes from the single Ethernet port on the Arris to one of the NIC cards on my little Dell 386 computer.  Nothing has changed physically in the house (maybe outdoors?).  Picture quality on TV seems unaffected.

    From Status: Interfaces

    WAN_CABLE interface (wan, xl0)
    Status up
    DHCP up

    IPv4 address <has been="" the="" same="" for="" a="" long="" time="">Subnet mask IPv4 255.255.254.0
    Gateway IPv4 <ipv4 as="" above="">.1/24
    IPv6 Link Local <not in="" use="">ISP DNS servers <don't recall="" setting="" these="">127.0.0.1
    75.75.75.75
    75.75.76.76
    68.87.76.182
    64.81.79.2
    MTU 1500
    Media 100baseTX <full-duplex>In/out packets 13644009/25123545 (12.34 GB/7.38 GB)
    In/out packets (pass) 13644009/25123545 (12.34 GB/7.38 GB)
    In/out packets (block) 567075/0 (62.24 MB/0 bytes)
    In/out errors 1158/0
    Collisions 0

    I guess the "in" errors might indicate something.

    I upgraded to this 2.2.4-RELEASE (i386) about a month ago (using the built in upgrade page) and it was about 1 week after that that I noticed the problems on the WAN connection.  It could be some esoteric setting that did not translate in the upgrade.

    Please let me know if any other info helps a diagnostic.

    Thanks so much,
    Chris.</full-duplex></don't></not></ipv4></has>



  • A little bit of Google pointed to this:

    http://forums.xfinity.com/t5/Basic-Internet-Connectivity-And/Re-keep-loosing-signal-on-Arris-TM-722/m-p/2346077#M213125

    Basically, the cable side of the device is likely sensitive to signal quality (power levels and SNR).  Walk the coax from outside your house to where is connects to the Arris;  if there are any splitters in there, see if you can get rid of them.  Most areas Comcast serves should be all digital (no analog TV signalling), so any splitters need to be higher quality and higher bandwidth than generic ones from Radio Shack or your nearest electronics store.

    It could still be a sw issue, but I'd verify physical connectivity first


Log in to reply