Pfsense 2.2.4 with Ezuce/Sipxcom SIP problems



  • Good day, After many long hours trolling google and the forum I decided to create an account to ask for help.

    My setup:

    Pfsense 2.2.4  WAN,  LAN,  VOIP interface.

    My problem is with the VOIP interface. My system seems to work perfectly only when I reboot the Pfsense box. After a min or 2 it will not allow a call to go out or in. I get a busy Dial tone when calling out/ I get to the Auto Attendant coming in however when I select an ext it drops the call, no MOH.

    I have set the NAT Outbound to Static.
    I have set the NAT Inbound Rules t0 ports, 5060,5061,5080 RTP 1024-65535 per ITSP requirements.  The Voip machine is running (Ezuce/Sipxcom).

    I duplicated my Nat Outbound rule to match the Inbound rule to ensure my header/ports don't get rewritten (Also Static Route).

    SipXbridge communicates on 5080, my ITSP communicates on 5060. So I have an Inbound rule Source 5060, redirect 5080
    In Advanced: Firewall and NAT. Firewall Optimization Options I have set to Normal. If I set it to conservative it will not work if I reboot the machine. If its set to normal and reboot router then it works for a few min.

    So I think this is where my problem is. If someone can assist me please I would appreciate it.



  • After doing more testing it seems that `the keep alive sip signaling is not properly keeping a pinhole open. It shuts down. I either have to reboot the pfsense router or go into sip setting and raise the number. eventually it reaches its mark and shuts down again.

    If any one has any idea please help me out.

    Thanks



  • Looks like the state table is the one creating all the trouble. I have disable PF Scrubbing.

    Going to see if this helps out. Any help would be great

    Thanks


Log in to reply