BT Youview IPTV setup



  • I'm new to this stuff, just as a little home project so still learning. Sorry about any misunderstanding or confusion beforehand.

    I've got a pfsense 2.2.4 box running in a virtual machine on a windows 10 NVR (I know there could be better ways of doing it, but hey ho. Power consumption, money and all) with a Qlogic BCM5709C diual gigabit NIC for WAN and LAN and then the rest of my traffic for the NVR etc is going through the onboard gigabit LAN. System is an old Dell Optiplex 360 with 4gb ddr2 and an Intel Core 2 Duo E6550.

    I have a BT FTTC connection with an average speed around 40Mbps with BT TV using a youview box connected to a switch via ethernet but I cannot get on to the premium IPTV channels like AMC or SyFy and it comes up with an error saying check my connection. It worked fine with my old BT homehub 5 (which died) but just plain won't work with the pfsense box. I've had a trawl through the internet for a bit but can't find anything which resolves my issue. There are some things saying I need to set up an ICMP proxy for it and seen some things on multicast settings but no nail on the head moments as of yet.

    So my question is, what settings would I need to change to get this to work?

    Thanks guys. Nothing too complicated, I'm only just getting into this stuff.  ;D



  • My FTTC connection is with Zen, who don't support YouView, so I never got deeply into this.

    You need an IGMP proxy running on the parent of your PPPoE interface for the YouView premium channels to work. https://forum.openwrt.org/viewtopic.php?id=52406 will probably give you some clues, though I have no idea whether the information is still current and it will obviously have to be adapted to pfSense. https://community.bt.com/t5/YouView-Boxes/Using-a-3rd-party-router-for-Multicast/td-p/1048582 may also help.

    Unfortunately I can't do any testing for you, as my connection is on the Zen LLU customer VLAN, not the BT Wholesale customer VLAN, so I won't have access to the multicast networks you are trying to access.


Log in to reply