Unable to boot after Hard Drive Replacement



  • Hello,

    Prior to changing my hard drive to 500 gig, pfSense was working fine with 80 gig. The motherboard model is an Asus K8N.
    The installation went fine with version 2.2.4 using the quick and easy method but ran into a boot issue after reboot.

    The system now hangs with an error.

    Error 1 lba 805407887
    Errpr 1 lba 805407887
    no /boot/loader

    FreeBSD/x86 boot
    Default: 0: ad(0,a) /boot/kernel/kernel
    boot

    Error 1 lba 805407887
    no /boot/kernel/kernel

    Any help would be much appreciated as I am not sure what further steps I need to do to rectify the boot issue.

    using SATA connection

    BIOS settings for hard drive:
    LBA/Large mode Auto
    Block (Multi-Sector-Transfer) M Auto
    PIO Mode Auto DMA Mode Auto
    SMART Monitoring  Auto 32 bit Data Transfer Disabled

    Thanks



  • A general guess would be something wrong with the 500G drive.
    Was this a new drive?  Any chance a previous install of something left some residue (this drive didn't come from a RAID setup did it)?

    You could try a custom install and make sure to do a full format and re-partition of the drive.

    Try the custom install and see what it reports.



  • Thanks divsys for your suggestion. I will definitely try the custom install. The hard drive is brand new.

    Regards,



  • If it's a new drive, then definitely do a custom install and watch what the geometry shows.
    Maybe some funky interaction with the BIOS interpretation of the the drive.

    Let us know what happens.



  • I tried the custom install but unfortunately I am still getting the same error. What I basically did was select the recommended settings with the custom install.



  • Any chance you can go back to the 80GB drive just to prove that it still works?

    I'd still bet on a BIOS weirdness, but it's worth proving that the system will boot at all.

    Any other SATA ports on that MB to try?

    Is this just a standard download of 2.2.4, no mods?

    Perhaps try a load from flash drive?



  • Did a little reading on the FreeBSD boards and there appear to be potential issues with the install of the boot loader and some SATA implementations.

    Does the BIOS have any settings for the HD interface mode -> IDE/SATA/AHCI (etc.)?
    These are usually in the "Integrated Peripherals" section of the BIOS or some such.

    Was the 80GB drive running 2.2.4?
    If not you might want tor try an older (2.1.5?) install first and then try an in place upgrade.

    I'm sure there's a way to get this puppy up and running, but without seeing the actual system I'm stuck imagining my trial and error procedures.


Log in to reply