More than one domain with DNS Resolver / Forwader?



  • So suppose my pfsense system is on the domain home.ninja (VLANS 100,200). This domain is for home and guest networks. I also have another domain say lab.jp for my homelab and management network (VLANS 400, 1). DNS resolving of static mappings doesn't work and from googling the log file output it seems its related to the how I have 2 domains.

    DHCP Log:

    dhcpd: Unable to add forward map from Apache-Pro.lab.jp to 192.168.1.12: not found
    

    None of the other logs have any errors including the resolver log.
    Any ideas?
    Thanks


  • LAYER 8 Global Moderator

    You can create what over rides you want.. If you want different fqdn to resolve just put them in over rides.. For example I have my isp gateway IP resolve to gateway.comcast.isp

    You can then hand out different search domains on your different dhcp servers.




  • Currently I have the main (ninja) domain as the system default and the lab domain under both the lab and management DHCP server configs under the override domain option. The clients get the correct domain but I can't resolve their hostnames with or without the full domain.

    Is there another place I need to override?


  • LAYER 8 Global Moderator

    What records do you have in your over rides?  You state domain over ride, well from you error

    Apache-Pro.lab.jp to 192.168.1.12

    Can you post up your over rides?



  • override

    override

    override

    override!

    What is this ' over ride' you keep speaking of?



  • Here are my configs









  • Banned

    WTH are you doing there? So, you top secret censored hostname is in some .ninja "I have invented this" domain, and you are passing godknowswhat.jp to clients? Your DNS resolver/forwarder knows nothing about godknowswhat.jp, sure like hell it won't register any leases there. Untick that box about DHCP leases registration.


  • LAYER 8 Global Moderator

    override – my bad ;)  Will watch that in the future... heheheehe  Sorry KOM...

    Also you do understand that .jp is a valid public TLD... Not something I would suggest you use on your internal hosts for resolution.. How about you use .somethingnotvalidonpublic as your tld this removes a lot of problems!!!



  • I actually own those domains.



  • @doktornotor:

    WTH are you doing there? So, you top secret censored hostname is in some .ninja "I have invented this" domain, and you are passing godknowswhat.jp to clients? Your DNS resolver/forwarder knows nothing about godknowswhat.jp, sure like hell it won't register any leases there. Untick that box about DHCP leases registration.

    So apart from you assuming that I don't know how domains work do you have any actual suggestions to fix my problem  that you restated at the end of your post? How do I let the resolver know that I also have the domain godknowswhat.jp as you put it?


  • LAYER 8 Netgate

    Host overrides in the DNS Resolver, bro.  What's so hard?



  • @johnpoz:

    . How about you use .somethingnotvalidonpublic as your tld this removes a lot of problems!!!

    I would consider that for my home network but some of the services in my lab I do want to expose to public Internet. I thought it'd be easier that the public domain reflects the internal domain as well.


  • Banned

    Neither the forwarder, not the resolver will do any zone transfers to public DNS servers. Plus I completely fail to see why on earth should the public DNS point to your RFC1918 IPs. It will be completely broken.



  • @doktornotor:

    Neither the forwarder, not the resolver will do any zone transfers to public DNS servers. Plus I completely fail to see why on earth should the public DNS point to your RFC1918 IPs. It will be completely broken.

    I am well aware of that they wont transfer to the public DNS.



  • Well friends it looks like its a bug in pfSense.

    https://forum.pfsense.org/index.php?topic=86791.0

    https://redmine.pfsense.org/issues/1819

    Thanks to those who actually tried to help.


  • LAYER 8 Netgate

    I didn't see that is was dynamic updates from DHCP to forwarder/resolver.

    Considering it's been a bug since 2.1 you can see how many people must rely on such functionality.



  • @Derelict:

    I didn't see that is was dynamic updates from DHCP to forwarder/resolver.

    Considering it's been a bug since 2.1 you can see how many people must rely on such functionality.

    Yeah I see how my use scenario is somewhat unique, hence why doktornotor is chewing me out.



  • Saw you linked to my post on the topic. Honestly I think this should be considered a true bug. The DHCP to DNS register scripts should never assume the FQDN pfsense resides in is the same for all DHCP clients. While i'm sure most home users are not doing complicated separated networks this is a very common thing in the enterprise world. (Don't lambaste me about doing DNS/DHCP with AD Domain Controller, I don't want to hear it and its not my use-case)

    Anyways to the point, I think that redmine bug report needs to be updated and attached to the current release because its likely being ignored due to old version number.

    Slightly off topic, I have been battling terrible unbound performance since the RC, I have updated root-hints and my DNS querys continually timeout requiring re-querying many times to finally get response. Perhaps i have the cache times set too low but still why would unbound be timing out all the time.


  • LAYER 8 Netgate

    Have you debugged all the root hints you've updated to be sure they're all responding?  Sniff port 53 on WAN and see where the problem really lies.


  • LAYER 8 Global Moderator

    "why would unbound be timing out all the time."

    You have shitty wan connectivity?  Your hitting shitty nameservers?  Nameservers are outside your region?  Last root hint update was May 23, 2015 so not something that needs to be updated all that often.  Are you having issues with IPv6 connectivity and your trying to hit the roots via ipv6?

    Lots of reasons why you could be having timeout issues to be honest.. Did you edit the cache time??  Not something you should normally have to adjust?

    So you have your DCs that are doing dns forward to your unbound on pfsense - maybe something in that process is slow?


Log in to reply