Squid caindo com Captive portal



  • Fala galera beleza?

    Tenho o seguinte cenário:

    Pfsense 2.2.4-RELEASE (i386)
    Squid3 + Squidguard

    E agora estou com um problema para implementar o Captive portal, procurei em todo lugar e não encontrei nada a respeito por isso to recorrendo aqui.
    Ao configurar a autenticação do Squid para funcionar com o Captive Portal (Squid>Authentication>CP) e após salvar as configurações o serviço do Squid e Squidguard param de funcionar.

    Estou tentando implementar um cenário com proxy transparente e autenticado onde são mostrados os logs do sarg por usuário, e por isso queria utilizar o Captive Portal.

    Alguém tem algum relato parecido com o mesmo cenário?

    Valeu galera!



  • Quando você ativa o Captive Portal o comportamento é tudo ficar bloqueado.
    É necessário uma tentativa de acesso na porta 80 para o CP entregar a tela de autenticação.
    Tentou dessa forma?

    Na aba principal do Squid existe uma opção para fazer um ajuste e permitir a integração entre eles…



  • Sim… dele precisar de um acesso na porta 80 eu ja percebi.

    Já ativei também na aba principal a opção para fazer a integração.

    O CP até funciona, o problema é que quando vou no Squid3 na opção Authentication > Authentication Method > Seleciono Captive Portal. Os serviços do Squid e Squidguard param de funcionar, e mesmo que tente inicializar eles voltam a parar.

    Estou tentando configurar desse modo para que no SquidGuard possa utilizar liberação/bloqueio por usuários e não por IP. Mas quero autenticar pelo CP. E também para poder utilizar os relatórios do Sarg por usuário.



  • Não tenho certeza, mas acho que dessa forma estava com um problema a integração, sei que até a versão 2.1.5 do pfSense estava…

    Vamos ver se tem mais alguém aqui que pode informar...



  • Pois é Tomas,

    Infelizmente deve esta com problema mesmo. Estive lendo em outro tópico onde o Marcelo informou que estava com problemas nos pacotes pbi e que seria resolvido na versão 2.3 do Pfsense.



  • Usa a versão 2.1.5 que funciona.


Log in to reply