3G modem as default gateway



  • Hi all,

    I have set up a lab environment to test if I can use one of my 3G modems as a gateway.
    Everything is working good so far.
    Modem recognized, PPP interface configured, Interface assigned to OPT1, added "all" allowed rules to both LAN and OPT1 for test purposes.

    When I want to create a new gateway for this interface I am faced with a problem. The PPP interface receives a dynamic IP from the ISP which uses a subnet mask of: 255.255.255.255
    So when I create my gateway it won't accept any IP address I give it because it is not in the same network, if I configure the gateway with a dynamic address it uses: 10.64.64.0

    The gateway does actually show as online when I use the 10.64.64.0 address and I can ping hosts on the internet through the gateway from Pfsense but I cannot route my traffic from my LAN interface through the OPT1 interface for some reason.

    Could my issue be with this gateway address or am I missing something?






    Thank you.



  • No one? :'(



  • Have you looked at the documentation for Dual WAN. I am assuming that is what you are asking. It looks like you have an existing WAN connection and you are trying to add 3G on OPT1 and want to use that as your gateway..
    For that you would use gateway groups.. Treat the 3G as second WAN.

    https://doc.pfsense.org/index.php/Multi-WAN



  • Hi Phishfry,

    Thanks for the reply. I managed to get it working. I was not trying to do multi-Wan but rather just use the 3G as my primary WAN.

    All I did was change my WAN interface to PPP0 instead of creating a whole new interface (OPT1) and assigning PPP0 to the OPT1.
    I was following this guide in which you create a new interace (OPT1): https://doc.pfsense.org/index.php/Configuring_3G_modems
    but I should have just assigned PPP0 to WAN from the start :)

    Cheers.



  • That is how I set up pfSense MiFi's - Modem on WAN, Local Ethernet on LAN and ATH0 on OPT1.
    Depending on your carrier you may want to consider OpenDNS. You may want to enable "Disable Gateway Monitoring" if you are on a data  limited plan. It constantly pings the gateway eating up data. It is under the >System>Routing tab on the menu..



  • @Phishfry:

    That is how I set up pfSense MiFi's - Modem on WAN, Local Ethernet on LAN and ATH0 on OPT1.
    Depending on your carrier you may want to consider OpenDNS. You may want to enable "Disable Gateway Monitoring" if you are on a data  limited plan. It constantly pings the gateway eating up data. It is under the >System>Routing tab on the menu..

    Will keep that in mind, thank you.


Log in to reply