Pfsense 2.2.4 locks up - no LAN, no GUI, no reboot, no crash dump..console works



  • First, forgive any ignorance I have with pfsense as I'm completely NEW to using it.  I built a new box with pfsense in mind a few weeks ago, installed 2.2.4 on it (disconnected), configured it and simply let it stay powered on for about a week to just make sure that the hardware wouldn't crash.  Hardware specifications are:

    X11SBA-L4NF: Intel N3700 with 4 Intel Gbit Ethernet ports and a single IPMI port (how I check the console)
    Sandisk 128 GB SSD
    Antec ISK 110 case with built in Antec 90W power supply
    2 x 4GB Samsung PC1600 DDR3L running at 1066 (haven't bumped it up as felt no need)

    (running 11 watts at wall if curious).

    Anyway, after connecting to the WAN, turning on DHCP and firing up for the first time, it ran for 30 minutes and then locked.  I had no LAN access, no GUI, no WEB.  I could, however, get to the console (I used a real monitor and keyboard the first time).  I finally rebooted to regain access.  I pulled the system out, reset to defaults, reconfigured with bare minimum and put back in.  After a day or so, it crashed again and this time, I used the IPMI port to check the console.  No messages and it was responsive.  I rebooted.  After reading around, I set the LAN and WAN ports to 1000T full duplex (no Auto Detect) to see if that would help.  It did not.  After running for 1.5 days, it stopped responding about 45 minutes ago.  The console was still alive with no messages.  After a few more minutes, however, the following message appeared on the console (see below).  After the message, the Internet partially worked.  Had to go in and disable IPV6 to get full Internet back.  Please note that IPV6 was not configured on the first or second crash.

    Any ideas would be greatly appreciated.  I've ran Memtest 86+ for many hours with ZERO errors.  Don't think it's hardware related but could be I suppose.  The system logs basically were normal until the Watchdog timeout and resulting link up and down of the LAN.  Thanks in advance….



  • Banned

    Looks like your igb NIC is not exactly stable, or needs some tweaks… Perhaps try "Disable hardware checksum offload" in System: Advanced: Networking.



  • @doktornotor:

    Looks like your igb NIC is not exactly stable, or needs some tweaks… Perhaps try "Disable hardware checksum offload" in System: Advanced: Networking.

    That was the only option that was 'unchecked'.  I'll try it and see how it goes.


  • Banned

    @Engineer:

    That was the only option that was 'unchecked'.  I'll try it and see how it goes.

    Oh noes…. wait - you enabled the horrible "polling" option? You might want to undo that tweak ASAP.



  • @doktornotor:

    @Engineer:

    That was the only option that was 'unchecked'.  I'll try it and see how it goes.

    Oh noes…. wait - you enabled the horrible "polling" option? You might want to undo that tweak ASAP.

    Sorry, no, it was unchecked.  I was at work and didn't remember them all.  Sorry about that.

    Looking at it again, of the "Disables", only the offload hardware checksum was unchecked.  Polling was never checked.



  • Leave everything there at their defaults. Make sure you've bumped nmbclusters (though that'd result in a diff error log generally).
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards



  • @cmb:

    Leave everything there at their defaults. Make sure you've bumped nmbclusters (though that'd result in a diff error log generally).
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards

    The second crash was everything at default.  The third crash was with the nmbclusters bumped to the recommended number for the Intel card.  I've tried turning off all hardware offloading for now and will see how it goes.  Been up for 1.5 days but it had done that before.  I'll report back.

    Off topic:  I've noticed that the chip runs hotter with PowerD turned on with "hiadaptive" than off (at least the first core).  Seems, from reading around, that PowerD allows 'turbo' speed to kick in whereas it will not kick in if PowerD is turned off (or another system setting is added).  I've turned PowerD off for now (default) for testing until the lockups quit.  Just found that interesting.


Log in to reply