Lost entire config



  • Hi,

    Been running pfsense for a year now, without any problems.
    Using HAproxy for ssl offloading.
    Since yesterday, my entire config seems to be lost.
    No installed packages, no firewall rules, no certificates, not even a default gateway.

    If I go to /usr/local/pkg, I still see all the the packages.

    Any idea's?



  • Go to Diag>Backup/restore, Config History tab. Should show history showing changes.



  • @cmb:

    Go to Diag>Backup/restore, Config History tab. Should show history showing changes.

    I looked there, and no changes visible. I did go back to my last change, unfortunately, that did not fix the problem.



  • Have you looked for the config.xml - or a similarly named file - under /conf? I assume you didn't take a backup any time previously and store the config elsewhere?



  • @muswellhillbilly:

    Have you looked for the config.xml - or a similarly named file - under /conf? I assume you didn't take a backup any time previously and store the config elsewhere?

    Unfortunately no  :-[, will do from now on. Guess I just have to rebuild my complete config.
    Something to do tomorrow :)



  • Although I limited the log size in the snort package, it had become over 40Gb in size.
    Deleted all the logs manually, rebooted, restored a config from yesterday, working. :)

    Going to keep an eye on my disk space from now on.
    Thnx for the help.



  • @AlphaSupreme:

    Although I limited the log size in the snort package, it had become over 40Gb in size.
    Deleted all the logs manually, rebooted, restored a config from yesterday, working. :)

    Going to keep an eye on my disk space from now on.
    Thnx for the help.

    could there be some way to keep an eye on such space via snmp ? syslog ?


Log in to reply