Carp crash of the backup



  • Hi,

    new to carp, and have a question on system crashing  ::)
    We bought this new shiny hardware, 2x SG4860. Pretty basic setup, carp for lan & another corp.network & some vlans, 2 different wan's. (actually the wan is one provider, but in dhcp. That's fine for us that we don't have 1 external carp ip)
    When I did the setup (convert existing setup to HA), and during failovers, I have had quite some crashes on the pfsense which has the backup state. (also when manually disabling carp on the master, thus generating a failover, the master becomes the backup and has a system crash. So it is not hardware I would think)
    During the reboot (because of the crash) the secondary takes over (=good thing), and after reboot it resumes master state. So far so good and it looks that carp is working fine, but I am wondering why it crashes so often?? I already removed all limiters (which I didn't like to do, but read some bug reports & recommendations so if we must, we must…)
    So off went the limiter (I even deleted the entries), but still we can make it crash. Time is also in sync (checked that as well), and I paid attention to nic order (as I read it was somehow also important)

    Any hints on where to look? TIA for any suggestion...

    Br, Benny.



  • The limiters would be the initial source of the crash I'm sure, can't use them with pfsync enabled. That's the only known thing that will cause crashes in that circumstance. Would need a crash report to tell more. Did you submit one? If so, from what IP? (can PM it to me if you want)



  • Hi Chris,

    I just double-checked, there were no limiters present in my setup at last crash (at least not visible in gui).
    I did submit the crash report, sent you some details by PM.
    Thanks for giving it a look !  :)

    Br, Benny.



  • I thought they had fixed the problem where the limiters would cause the backup system to crash.  I am guessing not since I just tried implementing limiters again on the latest version and it crashed by backup again.  I am on the latest version.  If it hasn't been fixed does anyone know when it will be fixed.  If it has been fixed then I need to figure out why it is still crashing.



  • @gordc:

    I thought they had fixed the problem where the limiters would cause the backup system to crash.

    No, you can't combine limiters and pfsync.



  • But this worked previously for me.  It has just been the last few upgrades that it has not worked.



  • It hasn't worked in any 2.2.x and newer versions, it's a problem in FreeBSD 10.x base OS versions.


  • LAYER 8 Netgate

    What's being done to fix it - and limiters in general? It has me stuck at 2.1.5 on several installs.



  • I am in a similar situation.  I have a number of firewalls that I have upgraded and need the limiters working.  I really don't want to revert back to 2.1.5


Log in to reply