Problema em fazer regra NAT para porta 3389



  • Boa tarde, li diversos casos aqui no fórum e todos apontam para soluções que já tentei e não consegui resolver no pfsense. Sou novo no pfsense, porém tenho conhecimento em iptables e faço tudo via comando, a princípio queria uma ferramenta mais rápida para fazer as regras mas já estou a dois dias batendo cabeça em algo tão simples no linux que realmente não estou entendendo ou não estou enxergando onde posso estar errando. Meu ambiente:
    Instalei em uma máquina com duas placas de rede o pfsense. WAN –-> LP de dados Embratel LAN ---> Rede Interna.
    Atribui corretamente os ips, realizei os testes de ping, tudo funcionando, inclusive fiz a regra de liberar pacotes ICMP para testar a comunicação. Até então blz.
    Fui fazer um NAT, o primeiro e único :
    Interface: WAN
    Destino: WAN Address
    Porta destino: 3389
    Redirecionar para ip: 192.168.10.1
    Porta de destino: 3389

    Reflexão NAT: <aqui já="" deixei="" como="" default,="" coloquei="" nat="" +="" proxy="" e="" puro="">sem sucesso
    Associação de regra: Deixei para adicionar uma regra de filtro associada.

    A regra de pass foi criada o NAT deveria estar funcionando mas não vai. Tentei diversas vezes e talvez eu esteja esquecendo alguma coisa mas já olhei e refiz a regra várias vezes e não tem mais onde mexer.

    Aguardo uma ajuda. Obrigado!</aqui>



  • Seja bem vindo!

    Seu problema me parece ser topologia… não está claro se o Gateway da sua rede é o pfSense ou o Router da Embratel.

    PRa dar certo teria que ficar:

    EMBRATEL--->(WAN)pfSense(LAN)--->Rede Interna

    Você precisa de um IP Válido na porta WAN do pfSense ou que a Embratel faça um DMZ pra você.



  • Obrigado pelo rápido atendimento Luiz. A topologia é exatamente essa, Roteador embratel <–---- WAN PFSENSE <-------> LAN Interna. Na Wan tenho um IP Válido no qual consegui pingar de outro link VIVO que tenho na empresa. Também consegui validar através do traceroute a saída até a chegada.



  • Segue a captura no pfsense:

    Em anexo a imagem da captura feita através do pfsense onde o final 113 é meu roteador embratel, final 114 é a placa wan do pfsense, e 106 é meu link vivo utilizado para tentar acessar o ip 192.168.1.118 TS através da wan 114. Nota-se que no anexo pfsense2.JPG que é a captura da placa WAN as requisições estão sendo repassadas, porém não há retorno.






  • pode ser que o problema não esteja no pfsense e nem na regra, e sim no windows server, já verificou isso?

    desativa completamente o firewall do windows, só para testar… se funcionar, vc sabe que é o firewall do win que está bloqueando... dai vc precisa rever as regras...

    também verifique se o gateway desse micro windows que irá receber o WTS está apontando para o IP LAN do pfsense.



  • No tcpdump, notasse que o equipamento não retorna na porta 3389. Desabilita o firewall do S.O e veja se irá funcionar.



  • chipbr, vc observou bem obrigado. Utilizava outro gateway nesse servidor, mudando para lan do pfsense deu certo. A dúvida agora é que estou em ambiente de teste no momento mas, no dia a dia não poderia mudar o gateway desse servidor.



  • se vc não pode mudar o gateway do windows, então terá que fazer uma rota manual nele apontando para o pfsense



  • @LFCavalcanti:

    Seja bem vindo!

    Seu problema me parece ser topologia… não está claro se o Gateway da sua rede é o pfSense ou o Router da Embratel.

    PRa dar certo teria que ficar:

    EMBRATEL--->(WAN)pfSense(LAN)--->Rede Interna

    Você precisa de um IP Válido na porta WAN do pfSense ou que a Embratel faça um DMZ pra você.

    Se o IP válido não estiver na porta WAN do PFSense não irá funcionar??



  • exatamente

    ou vc tem que fazer um NAT (ou um DMZ) do outro roteador para o pfsense e então fazer novamente o NAT dele para o servidor


Log in to reply