Can't get trim to enable



  • Version 2.2.6, using command: touch /root/TRIM_set; /etc/rc.reboot

    After reboot,  tunefs -p / shows trim still disabled.

    What am I doing wrong?



  • Same here.  I tried that first and then went through the steps outlined here ( https://forum.pfsense.org/index.php?topic=66622.0 ) and it was still disabled.  Haven't had time to get back to it yet.

    From the steps:

    **Login with SSH and open the shell.

    Run /usr/local/sbin/ufslabels.sh

    Add the line ahci_load="YES" to /boot/loader.conf.local

    reboot the machine

    Login with SSH and open the shell

    touch /root/TRIM_set; /etc/rc.reboot**

    I already had the ahci_load="YES" in the /boot/loader.conf.local.  Maybe I need to take it out, reboot and then go through the steps again.



  • TY for the help, did the same. No change.

    Added and removed and added again.

    Still getting the block error.

    I am insrallws on a Netgate RCC-VE 2440 myself.

    Sorry about sharing the misery but it's nice to not be alone in he problem

    I edited with vi and using the edit function in maintenance.



  • From here….
    https://forum.pfsense.org/index.php?topic=97554.0

    It would seem you could boot into single user mode (even on full install) enter the commands and enable TRIM.

    You would need your device name (might get that using the dmesg command and then doing the steps).  Might try later.


Log in to reply