Issue with pfsense-wireless AP interaction?



  • I'm running an up to date pfsense box multi-wan with two internet connections and three internal lans, but one LAN is currently unused, running on an old compaq compact desktop. It's been running fine once I sorted out the multi-WAN part for a couple of years and I thought when this problem cropped up initially that it might be connected with a LAN's NIC being potentially problematic so that was swapped out. At the same time I reinstalled pfsense but used the saved configuration to get it running again apart from handling the NIC change. There are no VLAN's, add ons etc involved and the rules for the two LANs are pretty simple as I've got things lock down tight and I and my users don't need any special rules for particular applications etc.

    What happens is that the wireless AP's start throwing authentication errors and quickly all four go offline. This last time was after only two days but the few previous times it's been many weeks/months apart. I'm in a large old stone house which is hard on wifi range so there is an AP on each floor plus one other and all set on spaced channels and different SSID's with clients getting their IP address from pfsense but access authorisation at the AP all using WPA2 with the same password. The AP's are two TP-links, a netgear and an Edimax router/ap with the router element disabled

    When this happens I stop getting access from the web interface and the attempt to log in produces the following message on the log in screen.

    'Warning: fopen(/tmp/config.lock): failed to open stream: Device not configured in /etc/inc/util.inc on line 127 Warning: flock() expects parameter 1 to be resource, null given in /etc/inc/util.inc on line 164 Warning: fclose() expects parameter 1 to be resource, null given in /etc/inc/util.inc on line 165 Warning: session_start(): open(/tmp//sess_a34349f7b8226c9d3453d08c159a7ea4, O_RDWR) failed: No space left on device (28) in /etc/inc/auth.inc on line 1359 Warning: fopen(/tmp/config.lock): failed to open stream: Device not configured in /etc/inc/util.inc on line 127 Warning: flock() expects parameter 1 to be resource, null given in /etc/inc/util.inc on line 164 Warning: fclose() expects parameter 1 to be resource, null given in /etc/inc/util.inc on line 165 '

    This I'm afraid makes almost no sense to me and therefore I can't start to figure out what might be going on to work towards a fix.


  • Banned

    Your /tmp is completely full. You won't see any fix for that.



  • Thank you. That I do understand unlike the message that came up on the screen. Hopefully I can take it on from here myself for now at least.

    Richard.


Log in to reply