Frequent Crashing



  • I just had another crash.  The report was submitted from the same IP logged to this post.

    History:
    I have never had crashes on this system before.  It has been in use for more than 1 year.
    I did recently move it into a new chassis and do not have a fan blowing directly on the CPU heatsink.  The temperature is reported as 38C which would seem okay to me.  I will be moving it back into a mini itx box with a fan to see if that helps.

    It seems like the crashes started shortly after upgrading to the latest snapshot about 2 weeks ago.

    I am running a Supermicro A1SRi-2558F with 8GB of ECC Ram.

    Thanks
    Chad


  • Netgate

    given that most of the pfSense team runs a 4860 at home, which is the same CPU, it's likely that you have flakey hardware.



  • @jwt:

    given that most of the pfSense team runs a 4860 at home, which is the same CPU, it's likely that you have flakey hardware.

    I guess it is possible that my hardware has just become flakey.  The thing was running Hyper-V server for 6 months without issue and pfsense before that so I am having trouble believing the hardware is bad but it did just crash again.  I have a fan on it and it has been running at 20C since yesterday's crash so its not heat.

    It is weird that it crashed right when I woke my desktop that runs my iTunes server up from sleep.  Not sure if that is a coincedence or not.  Maybe something with Bonjour on the desktop crashing Avahi on pfsense?  Could that cause the pfsense box to reboot?

    I am going to take it down and start running some tests on the hardware.

    I am running a transparent proxy and SquidGuard.  Avahi provides airplay across my guest network.

    Package Name Category Package Version
    Avahi  Network Management  1.10.3
    Cron  Services  0.3.2
    OpenVPN Client Export Utility  Security  1.2.20
    Sarg  Network Report  0.6.6
    squid3  Network  0.4.1.1
    squidGuard  Network Management  1.9.15



  • The system has been running prime95 blend for 9 hours now without errors.  I will let it continue for the rest of the day.



  • After a Prime95 burn in, Memtest+ possibly. You do have ECC memory, which should be able to correct single bit errors and detect most multi-bit errors.

    I'm curious. What is the crash message? Do you get the same error every time? Is it in a driver or just the general kernel?



  • @Harvy66:

    After a Prime95 burn in, Memtest+ possibly. You do have ECC memory, which should be able to correct single bit errors and detect most multi-bit errors.

    I'm curious. What is the crash message? Do you get the same error every time? Is it in a driver or just the general kernel?

    I am going to start Memtest+ here pretty soon.  Prime95 at 21 hours now with no errors.
    When I submitted the crash reports I think the system deleted them. Is there a way for me to see what the crash message was?  I browsed through the crash report before submitting but do not remember what the actual crash message was.



  • No crash reports submitted from the IP you're posting to the forum from. If you could post or PM me the IP the crash report would have come from, I can check it.



  • @cmb:

    No crash reports submitted from the IP you're posting to the forum from. If you could post or PM me the IP the crash report would have come from, I can check it.

    Looks like I got a new IP when I swapped the Verizon router back in.  The reports were submitted under:

    74.100.136.161

    Thank you.



  • Completed three passes of Memtest86+ overnight without error.



  • I think I might have found out what was making it crash.

    I just brought the system back up after running all the hardware tests.  The first thing I did was go to dslreports speed test and run a test.  pfSense rebooted during the upload portion of the test.

    These crashes started happening after I upgraded to 150/150 FiOS and started messing with CODELQ to try and get my bufferbloat score into the A range.  I think the shaper may be what was causing the crashes as I really never used these before.  I have turned the shaper off and will report back if I have any new crashes.


  • Netgate

    if you don't get anymore crashes, open a bug!


Log in to reply