Qos Pfsense 2.2.4



  • I'm try to setup Qos for phone network, using the default configuration. Once the Traffic shaper is completed. I test the using the HFSC default setting. I don't get any Qvoip trigger for when checking the Que.Is there something I'm missing using Traffic Shaper, with OOMA VOIP.



  • Trigger?

    Use firewall rules to catch the VOIP traffic. Then, in the rules' settings assign traffic the your VOIP queue.



  • I did what you have suggest .I did that Source VOIP Aliases IPV4 UDP Queue qInternet/qVoIP. When I look at the Queue i notices that I have alot of Drops on the qVoIP. Is that normal?

    When setup firewall rule do you use the Source VoIP Aliases and what is the destination WANnet or VoIP Net?



  • @chain:

    I did what you have suggest .I did that Source VOIP Aliases IPV4 UDP Queue qInternet/qVoIP. When I look at the Queue i notices that I have alot of Drops on the qVoIP. Is that normal?

    Drops would mean you are probably trying more VOIP traffic through the queue than you allocated.

    You need to allocate more bandwidth for VOIP, most likely.

    Edit: destination would prob be "not LAN net" unless you know the IP of your VOIP provider.



  • I did increase the size to 200kbits per sec that's working no drops. How about setup firewall rule do you use the Source VoIP Aliases and what is the destination WANnet or VoIP Net?



  • Everyone is guessing about what you are doing.  Post screens of your shaper config and floating firewall rules



  • @chain:

    I did increase the size to 200kbits per sec that's working no drops. How about setup firewall rule do you use the Source VoIP Aliases and what is the destination WANnet or VoIP Net?

    You apply the rule to the interface that your VOIP phones are on, setup the rule with source as the alias for the VOIP phones' IP addresses. You do not have to specify the destination unless you know which server(s) IP specifically your phones will connect to - in which case, you can further specify an alias containing the server IPs and put in the destination.

    For queue, because it's UDP, you do not need to specify the ACK queue - it will just be None/qVOIP.



  • I don't have a floating rule on the firewall just phone zone and shaper configuration that is the default setting I just adjusted it 200Kb. Do you what to see something different?






  • @chain:

    I don't have a floating rule on the firewall just phone zone and shaper configuration that is the default setting I just adjusted it 200Kb. Do you what to see something different?

    I see a rule that allows OpenVPN from the phones? Do the phones actually VPN back to the server? If so, you need to set the queues for the VPN rule since the traffic is tunneled internally.


Log in to reply