IPv6 broken after upgrade from 2.2.4 to 2.2.5 on nanoBSD



  • Hi,

    The upgrade from 2.2.4 to 2.2.5 when fine for the most part
    I have one issue, IPv6 is broken.

    When I upgraded to 2.2.4 I was advised on this forum to use the settings you can see in the attached screenshot.
    This setting doe not seem to work anymore with 2.2.5

    Can I get advice which settings to use to make IPv6 work again ?

    See screenshot

    When I disable " advanced" I also have the following settings enabled:

    Request a IPv6 prefix/information through the IPv4 connectivity link
    Only request an IPv6 prefix, do not request an IPv6 address



  • If IPv6 per PPPoE worked on 2.2.4 it should work on 2.2.5 with fresh booting.
    Did you test a cold reboot or MoDem reboot after the upgrade ?



  • Yes I did reboot multiple times
    I have no modem, its a glas fiber connection



  • I see this error in general logging

    php-fpm[91194]: /rc.newwanipv6: The command '/sbin/route change -host -inet6 xxxxxxx returned exit code '1', the output was 'route: writing to routing socket: No such process route: writing to routing socket: Network is unreachable change host xxxxxxx gateway xxxxxx fib 0: Network is unreachable'



  • And this under "Gateways" logging

    apinger: Could not bind socket on address(xxxxxxxxxxxxx138%pppoe4) for monitoring address xxxxxxxxxxxx%pppoe4(INET_DHCP6) with error Can't assign requested address



  • under "Resolver" logging I see

    unbound: [40341:0] error: can't bind socket: Can't assign requested address for xxxxxxxxxxxxxxxx



  • You're not using /122 subnets anymore, but /64 right ?  ;)

    tip: Stop using Apinger, [System: Gateways: Edit gateway] check Disable Gateway Monitoring.

    Check if there is only one dhcp6c client running, command prompt {ps ax | grep dhcp6c}, else kill -9 {PID}

    Another probable issue:
    After rebooting you need to stop/start the system again [Statust: Interfaces] in order to get the real Alix-WAN fe80:MAC address i.s.o. the randomized fe80:blabla. Because else after 2 hours or so the renewal of ISP lease will not work ?



  • I did a restore of a backup of my configuration (XML file)
    After the restore and a reboot, IPv6 starts working again.  :)
    Its' now installing the packages again. (this will always take a while)
    I wil report back here if the IPv6 connectivity stays stable

    Thanks for the help and tips so far



  • My IPv6 was not working (tracking IPv4) after the initial upgrade reboot.

    I found this thread, and decided to reboot again before doing a restore, and now my IPv6 is working.

    Just my 2 cents.

    Thanks,
    Frank



  • @nicholfd:

    My IPv6 was not working (tracking IPv4) after the initial upgrade reboot.

    I found this thread, and decided to reboot again before doing a restore, and now my IPv6 is working.

    What type of v6 connectivity?



  • Just wanted to let you all know my IPv6 connection is still up & running and stable since november 11
    :)



  • @cmb:

    @nicholfd:

    My IPv6 was not working (tracking IPv4) after the initial upgrade reboot.

    I found this thread, and decided to reboot again before doing a restore, and now my IPv6 is working.

    What type of v6 connectivity?

    My provider is Comcast.  I'm running the full pfSense on an RCC-VE 2440.  I've set IPv6 on the WAN interface to DHCP6.  The LAN interface is set to Track Interface.  Before the 2nd reboot, I lost my IPv6 address on all interfaces, and the systems on my home network lost all IPv6 addresses except the local ones.  After the 2nd reboot, they came back, and the machines on my LAN received IPv6 addresses, too.  Verified by browsing to http://ipv6.test-ipv6.com and getting a 10/10 score.

    Screenshots of after the 2nd reboot are attached.



    ![WAN 1.png](/public/imported_attachments/1/WAN 1.png)
    ![WAN 1.png_thumb](/public/imported_attachments/1/WAN 1.png_thumb)
    ![WAN 2.png](/public/imported_attachments/1/WAN 2.png)
    ![WAN 2.png_thumb](/public/imported_attachments/1/WAN 2.png_thumb)


    ![LAN 2.png](/public/imported_attachments/1/LAN 2.png)
    ![LAN 2.png_thumb](/public/imported_attachments/1/LAN 2.png_thumb)



  • Thought I'd give me recent experience as well after upgrading to the latest.

    Noticed one day that my IPv6 connectivity to the internet was down.  Connecting to the pfsense fw via v6 was fine and ssh'ing into it and doing an ipv6 ping to google.com also worked.  The problem was that the fw would not forward the packets from the LAN to WAN if they were v6.

    At the time I rebooted the modem (with Teksavvy) and then the firewall.  At that point everything worked fine and I chalked it up to some random thing.  Last week I experienced the same thing in that v6 connectivity to the internet was broken. I rebooted the fw and things worked again.  Last night I noticed it wasn't working again. I rebooted the fw just now and connectivity is re-established.

    At this point I don't know whether to blame Teksavvy or the current version of pfsense.  But I will say that I never had this issue with the 2.2.4 version (the previous I was using).

    LoboTiger



  • Up time of 4 days 22 hours and I just noticed that my IPv6 connectivity is not working again.

    PS C:\WINDOWS\system32> tracert -6 www.google.com

    Tracing route to www.google.com [2404:6800:4003:c01::93]
    over a maximum of 30 hops:

    1    <1 ms    <1 ms    <1 ms  lazerbeak.decepticon.com [2607:f2c0:f00f:bf00::1]
      2    *        *        *    Request timed out.
      3    *        *        *    Request timed out.
      4    *   
    PS C:\WINDOWS\system32> ^C
    PS C:\WINDOWS\system32>

    But from the pfsense shell it works:

    [2.2.5-RELEASE][root@lazerbeak.decepticon.com]/root: traceroute6 www.google.com
    traceroute6 to www.google.com (2404:6800:4003:c01::69) from 2607:f2c0:a000:1a1:20d:b9ff:fe26:9660, 64 hops max, 12 byte packets
    node-4stuntjjinixfi60poh.ipv6.teksavvy.com  7.386 ms  8.482 ms  7.620 ms
    node-66fkdz9gw7207f2o.ipv6.teksavvy.com  7.961 ms  8.032 ms  7.271 ms
    3  2001:4860:1:1:0:160d:0:5  7.639 ms  8.173 ms
        2001:4860:1:1:0:160d:0:1  7.826 ms
    4  2001:4860::1:0:7139  7.703 ms
        2001:4860::1:0:713a  7.547 ms
        2001:4860::1:0:7139  7.870 ms
    5  2001:4860::8:0:9154  222.752 ms  226.890 ms
        2001:4860::8:0:833f  21.088 ms
    6  2001:4860::8:0:699a  61.676 ms
        2001:4860::8:0:6999  71.005 ms
        2001:4860::8:0:699a  64.107 ms
    7  2001:4860::8:0:61e0  73.559 ms
        2001:4860::8:0:61e1  65.882 ms  65.244 ms
    8  2001:4860::8:0:81ac  165.414 ms  166.119 ms  158.051 ms
    9  2001:4860::8:0:96e9  222.310 ms
        2001:4860::8:0:8877  230.344 ms
        2001:4860::8:0:96e9  222.193 ms
    10  2001:4860::2:0:ab29  225.584 ms
        2001:4860::2:0:ab28  229.644 ms
        2001:4860::2:0:ab29  226.031 ms
    ^C
    [2.2.5-RELEASE][root@lazerbeak.decepticon.com]/root:

    Any suggestions?  I'll be rebooting it this evening.

    LoboTiger



  • FYI, 9 days after the last reload my IPv6 stopped working again.  I've downgraded to 2.2.4 to see if that makes a difference.  I'll post back if things remain more stable over the holidays.

    LoboTiger



  • I had to reboot a couple of times during the holidays for other reasons not related to this issue but I thought I'd post to say that I've been running for 24 days straight without any IPv6 connectivity problems while staying on 2.2.4.

    I'm tempted to upgrade to 2.2.6 but not sure if it's worth the trouble unless there's been a bug of some sort identified.  A friend of mine setup pfsense with 2.2.6 and he's had these IPv6 connectivity problems very similar to what I've experienced.  A reboot of his fw always seems to solve the problem.

    I'll post again to give another update next month.

    LoboTiger


Log in to reply