Only Microsoft DNS not resolving



  • Hopefully its not to obivous on what i may have not configured right., But here is the issue.

    I'm running the current PFsense version, and as long as your not using microsoft, which most all of my systems all run linux. When i try and connect a MS machine be it a regular pc, or a virtual box running any flavor of ridiculous microsoft there is no dns able to resolve, all the linux machines have no problem, its just the stupid microsoft ones. I've searched lot of places and they all talk about the dns forwarding, but with the current version of PFsense Unbound takes care of that right out of the gate and uses the dns you put in the general setup tab. Which works fine for linux, just not microsoft. Anyone got an idea i would appricate it.



  • On the basis of the information you've provided, I can only pose more questions at you rather than offer immediate solutions:

    Are you using DHCP to connect both your Linux and MS machines, or are they using static addresses?
    Have you run ipconfig /all on your Windows client(s) to see what IP and DNS they're using? If so, are the entries correct?
    Have you tried running an nslookup from your Windows clients to see if they can resolve hosts, assuming your clients have correct IPs/DNS?
    Have you checked to see if your Windows client(s) have their personal firewalls enabled? If so, does turning this off help?
    Are you running a Windows domain internally? If so, you should not be relying on the PFS for your DNS/DHCP, but should rather use your Windows DC to provide this.

    All guesses, of course. But if they're wide of the mark, then you'll have to provide more information if you want a solution.



  • Yes, the MS machines are using DHCP from the pfsense box, yea i've ran ipconfig, ipconfig /flushdns /release, /renew and even netsh winsock reset. Running an nslookup in ms just times out, the firewalls are all turned off all the way to the domain level, and as for Domains, i would not run a Microsoft domain or AD if my life depended on it on my business network. Mine are all bind domains, and run on Fedora 23 now. i do have one Ubuntu 14.04 webserver but thats getting moved over to Fedora 23. I am running an internal DNS server you can do a dnsstuff.com lookup on my domain destinyc46.net behind the PFS router. I do appricate you looking at this for me though, I i'm missing anything else or anything else you can think of let me know.



  • Ok, so what do you see when you run an 'ipconfig /all' on your Windows client? Does this show the correct IP range and DNS server? Does, for instance, the DNS server for your MS clients match the address of the DNS server entry for your Linux clients?



  • Yea it shows the info it pulls from pfs which is

    192.168.1.119 <= client address
    192.168.1.1    <= Gateway
    192.168.1.1    <=DNS

    and the mac for either the pc or the virt-manager machine. I know it has to be something i have set wrong in pfs, because the same machine can connect to a wifi router(netgear) that i have thats running on another inet connection and the dns resolves there its just something i know i have setup wrong in pfs, theres no big hurry on this one cause i really don't have any ms boxes running on my business network anyways, and if i do there all created on virt-manager really i just thought maybe someone ran across this issue, i really appricate your looking at this but dont spend alot of time on it dude.


  • LAYER 8 Global Moderator

    "but with the current version of PFsense Unbound takes care of that right out of the gate and uses the dns you put in the general setup tab"

    unbound does not "forward" out of the box - current version of pfsense uses unbound yes, but it is not forwarding anywhere.  It is does full recursion, starting with roots down..  What that would have to do with linux or ms doing a query to it would be ZERO..

    Why don't you do a simple query, using nslookup, dig, drill, etc.. and what does it return.. Sniff on pfsense if you want..

    Did you F with the default lan rules?  And set to tcp only?  Maybe linux dns client is doing tcp quick than windows.. How exactly do you know dns is not working?  You browser?  Ping, actual dns query?



  • Nope on the lan rule change. and here is the following nslookup info.
    nslookup destinyc46.net
    Server:        192.168.1.17
    Address:        192.168.1.17#53

    Name:  destinyc46.net
    Address: 50.2x.1xx.6x

    this is nslookup from my Ubuntu box with dns
    Windows 10 Virtual Machine

    c:\users\ nslookup destinyc46.net
    DNS request timed out.
    Server Unknown
    Address: 208.180.42.100

    DNS request timed out.

    I did enable the DNS fowarder service and still has issue.



  • Why are your Windows boxes trying to talk to 208.180.42.100, which resolves to rdns02.suddenlink.net?  You get a QUERY REFUSED response from that DNS.


  • LAYER 8 Global Moderator

    Well yeah 208.180 is not answering your dns query - what does that have to do with pfsense??

    ;; QUESTION SECTION:
    ;100.42.180.208.in-addr.arpa.  IN      PTR

    ;; ANSWER SECTION:
    100.42.180.208.in-addr.arpa. 86400 IN  PTR    rdns02.suddenlink.net.



  • Is it possible that you have your Windows hosts configured to get an IP via DHCP but you have static DNS?



  • Well that was what was in the general setup screen for dns server, but that has been changed from 208 that is no longer in the dns list of servers.



  • but that has been changed from 208 that is no longer in the dns list of servers.

    Then why does the nslookup output refer to it??

    OK, let's stop guessing.  Can you please provide screenshots of the following:

    Your Firewall - Rules - LAN
    Your System - General
    Your Services - DNS Forwarder settings
    Your Windows IP4 settings
    Your output of ipconfig /all
    Your output of nslookup destinyc46.net


  • LAYER 8 Global Moderator

    The forwarder does not hand dns to client, the dhcp server does that.. And there is no setting in there to hand off what is in the general tab.. You would have to manually have put that in there..

    Note: leave blank to use the system default DNS servers - this interface's IP if DNS Forwarder or Resolver is enabled, otherwise the servers configured on the General page.

    Only way it would hand client something you have setup is that you don't have the forwarder or resolver enabled..



  • Ok it's fixed, thanks for you suggestions dudes finally figured it out, it was dns settings in wrong order on the dhcp server.


  • LAYER 8 Global Moderator

    wrong order???  Why would there be an order??  If you want pfsense to be your dns, that is ALL there should be…  You don't use pfsense "and" list say google or 208.180 that doesn't even answer your query anyway...  Google doesn't know SHIT about any of your local devices, so is completely and utterly pointless to have the possibility for clients to ask google directly for anything and defeats the whole Fing reason for running dns on pfsense.

    If you are running forwarder or resolver your dhcp server should have ZERO anything in there for dns, since it will point to the IP address of pfsense on that interface which is correct..


Log in to reply