Gateway na mesma rede PFSense não faz Balanceamento nem FaillOver



  • Bom dia meus caros

    Tenhos 2 gateways aqui na instituição com a tecnologia MPLS (estão na mesma rede 192.168.17.0/24) e eu não consigo configura-los para que quando um link cair o outro assuma automaticamente e também o balanceamento não está funcionando.
    Sabem se tem algo haver por estarem na mesma rede? Pois eu fiz exatamente como os tutoriais e aqui não esta funcionando.

    Alguma dica?

    Abc.



  • Tentou trabalhar com gateway groups?



  • Sim m4kin, coloquei os 2 gateways no mesmo grupo com o tier 2 nos 2 gateways.

    O que eu estou achando estranho é que no status dos gateways as vezes os dois links aparecem como offline mas os 2 estão funcionando normalmente.
    Será que pode ter haver com o nat automático que vem configurado por default junto ao pfsense?



  • coloque no Monitor IP o dns do google ou telefonica



  • Pronto, agora ta correto.
    Mas eu fiz varios testes e a rede não balanceia.

    Inclusive eu tirei o cabo direto de um dos gateways pra ver se o outro assumia, mas nao assume.. E o status dele fica com Offline.

    Lembrando que segui esse tuto:
    http://www.tecmint.com/how-to-setup-failover-and-load-balancing-in-pfsense/



  • @cavazzani:

    Sim m4kin, coloquei os 2 gateways no mesmo grupo com o tier 2 nos 2 gateways.

    O que eu estou achando estranho é que no status dos gateways as vezes os dois links aparecem como offline mas os 2 estão funcionando normalmente.
    Será que pode ter haver com o nat automático que vem configurado por default junto ao pfsense?

    tenho 4 gateways aqui, com NAT automático, balanceamento normal.

    Vc lembrou de colocar nas suas regras de firewall para usar a conexao da lan passando pelo gateway group?



  • m4kin já descobri o problema.

    O PFsense não funciona bem com gateways na mesma rede em uma interface.
    Exemplo, tenho uma rede MPLS aqui que tem a rede 192.168.17.0/24 configurada no gateway, ai quando configuro esse gateway no pfsense o upload não funciona bem, os anexos de e-mails por exemplo falham.

    Deve ser esse o problema.



  • Não sei se ja resolveu, eu estava a dias tentando fazer balanceamento também com 2 links que tenho vivo speedy, um link chegava no limite as vezes até ultrapassava porem o outro no grafico não entrava nada.
    o que no meu caso resolveu, foi adicionar o grupo gateway na primeira regra do firewall, pois ja tinha algumas regras e adicionei a do gateway por ultimo e não funcionava, então apenas alterei a primeira regra da minha rede LAN adicionando o grupo gateway que fiz e foi :)

    http://prntscr.com/96fh6u



  • Só aproveitando o gancho, FailOver de links de internet com squid2, alguém tem utilizado, está funcionando bem nesta última versão do Pfsense?


Log in to reply