Intel PRO/1000 speeds


  • Banned

    I have 2 NIC's installed in my pfsense box. one is an i350T4 (igb0-3) which works fine. The other is an Intel PRO/1000 (em0) PCIE.
    I cannot get the Intel EXPI9301CT to work any faster than 100 BaseTX.
    I tried straight and crossover cables with and without a gigabit switch.
    Tried the advanced interface settings. When I set to 1000Mbps, the network goes down. Default and auto set the speed to 100 BaseTX.

    This NIC works fine in a Windows computer with the correct speeds.

    Pfsense is in a live environment so I do not want to take it down to pull the card. Is there a way to check the details on the NIC, like chipset info.
    I believe this card is an Intel EXPI9301CT. I know it is an Intel PCIE X1 card

    This is the info from dsemg.boot file
    em0: <intel(r) 1000="" pro="" network="" connection="" 7.4.2="">port 0xe000-0xe01f mem 0xf7cc0000-0xf7cdffff,0xf7c00000-0xf7c7ffff,0xf7ce0000-0xf7ce3fff irq 18 at device 0.0 on pci3
    em0: Using MSIX interrupts with 3 vectors

    How do I achieve 1000 BaseT speeds on this card?</intel(r)>



  • Some switches don't go into Gigabit Master mode and for some reason, neither does the Intel adapter by default in pfSense. I've also seen this behavior with em(4) NICs plugged into certain Cisco ISR routers.
    Are you using a managed switch or a dumb switch?

    If using a managed switch, see if you can force the port into Gigabit Master mode for negotiating links. That generally fixes the problem. In Windows, the Proset drivers does have this option and it fixes the issue all the time when I have the NIC set to Master mode.


  • Banned

    I used a dumb switch. I also tried direct to the NIC without a switch as I do on the other NIC, which is working fine.
    The unmanaged switch shows gigabit to the computer, but only 100 to the pfsense NIC.

    Don't have or want a managed switch for just one computer. That is what I use pfsense for. The only interface that goes to a switch is the LAN, which is from the i350T4 NIC. The other 3 ports on the i350T4 plug directly into computers.
    The unmanaged switch shows gigabit to the computer, but only 100 to the pfsense NIC.


  • Banned

    If I connect the pfsense port to a gigabit switch it only shows 100baseTX <full-duplex>in the dashboard.

    Can anyone confirm that the Intel EXPI9301CT does run at 1000baseT</full-duplex>



  • Yes it does. Where you get 100 Mb and have gigabit on both sides, it's almost always because of the cable. Using CAT-5 rather than CAT-5E or better, or just a bad cable.


  • Banned

    Tried 2 cables. Both CAT6. Then tried another CAT5E and that worked. Got full speed now.
    Thanks all.



  • Or just two bad cables. :) Glad that fixed it.


Log in to reply