Mitac PD11BI (Intel D2500CC2) boot problems USB stick



  • Hello guys,

    I am stuck on the booting from USB. The motherboard is in default in UEFI mode. I have changed the boot order to USB key first but no luck.

    When the system starts it goes directly to the bios setup. If the usb bootable usb is inserted and a reset then on boot nothing happens and it goed straight to the bios screen again.

    I have tried legacy mode but then on reboot my system goes on hold with a | almost in center fixed and nothing happens.

    I have a mitac PD11BI motherboard, 4 gig crusial sodimm, 60 gig king fast ssd, m350 eclosure with pico power supply.

    For the setup of the usb i formatted, Rufus plus the appropriate amd64bit memstick version pfsense image.

    Any body any thoughts or hints 😊

    Oja ps how to flash the bios. And is is importent for pfsense ?





  • Did you find a solution for this?

    I have the same problem with the same motherboard. I have set boot to legacy mode and manually selected boot device on startup. It doesn't matter if I try to boot from a USB stick or connected USB\DVD nothing happens. I have tried both AMD64 and I386 versions of the memstick and CD Installer.


  • Rebel Alliance Developer Netgate

    Try a 2.4 snapshot:

    https://snapshots.pfsense.org/amd64/pfSense_master/installer/?C=M;O=D

    Hopefully that works. If it does boot, the installer there has UEFI support.

    It's in an alpha state so expect a lot of things to be shaky, but it's worth trying.


Log in to reply