Pulling my hair out !! Cannot access the web gui pfsense after install VICTORY



  • Hey guys,

    I have a problem i cannot access the web gui after installation. I assigned WAN and LAN and i double checked if i mixed up the ports etc.  The default IP is shown 192.168.1.1/24. But when i go to my browser no go. Direct input from the LAN pf sense to my laptop.

    I have the following motherboard: Mitac PD11BI (Intel D2500CC2) with realtek NICS. This board is used by other Pf sense users.

    I did the install by USB memstick pfsense 64 bit edition. BIOS in legacy mode.

    The NIC cards showing ok in the setup. Also when i plug in cables they turn up.

    Hope you guys have some tips…..

    Greets,

    HJ



  • What ver of pfSense did you load?
    Basic install including DHCP?
    Is your laptop set to automatically pull DHCP from LAN?
    Did you try a (one time) initial reboot of pfSense?
    Can you get to the pfSense console?
    Can you ping the pfSense LAN address from your laptop?



  • Hey,

    • The latest version of pfsense (stable) memstick USB 64 bit
    • I connected a monitor to the pf sense box, with keyboard
    • Did not ping yet to the box
    • Laptop set auto for dhcp
    • Did reboots, default setup reboots, reinstall etc

    gr,

    HJ



  • Are you trying to go to

    https://192.168.1.1/

    or

    https://192.168.1.1/24



  • 192.168.1.1

    Its like my computer is not on the same page as the Pfsense box but the box is on DHCP and my laptop on auto so i cannot figure out the problem….



    • Laptop set auto for dhcp

    Did you configure DHCP during pfSense initial setup?



  • Yes its on DHCP…

    How to check this ?

    I just get the console screen with the setup options. Assigned the interfaces according.

    My motherboard has: Realtek RTL8111G-CG lan interfaces could that be an issue ??



  • When you installed pfSense and assign IP addresses to your NICs, it will prompt you to enable DHCP on that interface and then ask you for DHCP pool range.  If you didn't configure pfSense to be a DHCP server then that would explain why you can't get to the GUI.  If you run a DOS box on your client, and type ipconfig /all, what is your current IP address?  I'm guessing it's a 169.254.x.x address.  Either reset to factory defaults and then reconfigure and enable DHCP, or manually set your client to an unused static address like 192.168.1.50 with a gateway of 192.168.1.1 & netmask 255.255.255.0 and then try to access the GUI again.



  • I can change all that with option #2 in the console….! I did not get those items in the initial setup.

    My motherboard has: Realtek RTL8111G-CG nic cards could that be an issue ?


  • Banned

    ShitTek has never been an issue!



  • Does your box get a WAN address?

    If yes, then you can test the NIC's by swapping the assignments in the console.

    Have you tried to go to a shell on the console (Menu item 8 ) and see if you can ping items on your LAN (and/or get out on wan to 8.8.8.8, google.com , etc.)



  • My motherboard has: Realtek RTL8111G-CG nic cards could that be an issue ?

    No.  I suspect that you overlooked the DHCP stuff during initial install but maybe the memstick image is different?  I don't know.  Go with #2 and reassign your LAN interface.  It will prompt you for DHCP server details after you have given it an IP & subnet bit count.

    You didn't say what your client IP address is when you can't hit the GUI.


  • Banned

    Does the notebook get an IP? Should not be that hard to find in the Network area of your OS.

    If not: Assign manually an IP, e.g. 192.168.1.10 and try again with your browser… try both, http://192.168.1.1 as well as https://192.168.1.1



  • I made a fresh install with the reccomendation as here above. Still the same result.

    In the setup i get the option to assign the NICS (re1/ re2) WAN / LAN.  That goes well. Then it will configure it etc. Back to the console screen i have WAN (NO IP) LAN 192.168.1.1/24 below that all the options.

    I did not have to manual put in DHCP settings or IP addresses, subnet etc etc.

    This version of Pf sense i installed: pfSense-memstick-2.2.5-RELEASE-amd64.img.gz

    I don,t have a optical drive in the build.

    About the NICS i know Intel is better then realtek. I am good with computers but networking is something else. Trying to get there.

    This is the interface setup:

    1. WAN (re0 dhcp, dhcp6)
    2. LAN  (re1 static)

    Is this correct ?


  • Banned

    So we still got NOTHING to work with.

    As asked above:

    • post the output of ipconfig /all from the client
    • post the output of ifconfig from the pfSense box
    • post the output of ping<pfsense_lan_ip></pfsense_lan_ip>

    This works out of the box, just what you are doing there?!



  • Funny I had the same problem then realised I was on the wrong nic LOL

    It confused me for a while as it put the same subnet on the lan side as I have on my network wan side  ??? could do with perhaps using a different subnet as default maybe?

    Pull the network lead out and then put back in works for the wan side if you cant ping anything. Seems to wake up some nic's.

    On the lan side have you tried it with fixed ip if you haven't got dhcp working try, 192.168.1.10 with 255.255.255.0 and see if that works.



  • Just another thought have you checked "ipconfig /all" on your laptop (if its windows) and see if its on the right subnet ?

    Then see if you can ping it form the command prompt.



  • See the pictures.

    No response on the ping to the LAN 192.168.1.1

    I start regretting not buying a pfsense brand box ha ha  :o

    Also i have PIA VPN software running but that was switched of and the virtual interface shut down. Only direct on my NIC card from the laptop. (killer networking)








  • Just as I suspected.  You're not getting an IP address or DNS or gateway or anything.  MY original advice still stands.  Either configure LAN to serve DHCP, or set your laptop to a static IP address in the same subnet as the router (eg set it to 192.168.1.50, netmask 255.255.255.0, gateway 192.168.1.1, DNS 192.168.1.1).



  • In your console picture there is 192.168.1.1 255.0.0.0 - that is wrong. You have put /8 somewhere along the way. It should be /24 - 192.168.1.1 255.25.255.0

    If your front-end network in front of pfSense is already using 192.168.1.* then either change it, or change the pfSense LAN-side subnet to something different. It will not work with the same or overlapping IP address-subnets on WAN and LAN. You can change the pfSense LAN from console menu (2).



  • I had the box only lan connected direct to the laptop.

    Wen the WAN is connected nothing comes in from the cable modem. But thats another thing. That i guess is my type of modem and ISP item. It is a router/ modem i had my ISP set to bridge mode, so only modem function. As a router i now have apple TC.

    Modem - TC - Switch and that has to become modem - pfsense - switch (and then the apple tc in AP mode for the wifi)

    Thanks for the feedback guys.

    I will work on it and will report back here.



  • @captain1980:

    See the pictures.

    No response on the ping to the LAN 192.168.1.1

    I start regretting not buying a pfsense brand box ha ha  :o

    Also i have PIA VPN software running but that was switched of and the virtual interface shut down. Only direct on my NIC card from the laptop. (killer networking)

    What you have there is a self assigned ip address. I.E No dhcp from pfsense box by the look of it or cable disconected. So you need to set the ip address on the adapter on that machine (laptop), try 192.168.1.10 and 255.255.255.0 if that works you can set up the dhcp server once you log in from there.

    IF NOT then Follow the good advice from the previous posts and configure the interface to give dhcp for the lan, do this from the monitor and keyboard attached to the pfsense machine I think it is option 2. Folow the prompts and DONT set ipv6 and see if that works. Let us know.

    Just a thought you arn't connecting the laptop directly to the nic on the pfsense box are you ??? I.E. direct cable, you may need to have a network switch in between as some nics don't auto negotiate.



  • Thanks for the reply. I am going to try some stuff out today.

    Just a question in between: i stumbled upon a site/forum via Google that described a similar problem i have. There the conclusion was a problem in the BIOS.

    http://www.hardforum.com/showthread.php?t=1715302&page=2

    Something to do with ACPI does that ring a bell for computers pro,s on this forum ?

    If i don,t get it to work i will buy a Intel NIC board

    Something to do with ACPI does that ring a bell for computers pro,s on this forum ?

    If i don,t get it to work i will buy a Intel NIC board

    http://www.minipc.de/catalog/il/1775

    like i should have done see the above board in the first place since it was the same price as the board i have now below

    http://www.minipc.de/catalog/il/1866

    I went for the more cores and memory option. But should gone for the better NICS.

    Keep you posted.

    :o



  • Crikey could be an acpi problem !!!!! if you think it is change the nic. Or swap the interfaces around so WAN becomes LAN, if, they are different makes of course. I have used 15 year old D-Link 100mbt cards with no problem to test this software. Maybe you have something in the junk box?

    BUT have you used another laptop or pc (or borrow one) to see if you can access it that way

    Remember you can only access the web gui from the LAN side initially not the WAN like on other products.

    Sorry starting to run out of things to suggest now :(  maybe one of the gurus on this site will help you out.

    That mini pc looks nice what sort of box would you put it in ?

    Remember keep IT simple  :)



  • Its a mini ITX board. Both NICS are the same. Fixed on the main board.

    See the pictures of my setup. Tell me where i go wrong. It looks right.

    Setting up your own router great project….. running cables across the house, kitchen table full of stuff... GF happy (not)  :D









  • LAYER 8 Global Moderator

    Dude your not getting an IP address from your screen shot..  Your not going to be able to ping 192.168.1.1 from a 169.254 address..

    So either your cable is BAD, or your not auto crossover…  Is one of the interfaces gig at least?  If its a 10/100/1000 interface it should support mdix (autocross)... If you can not get an IP from the pfsense dhcp server then no your not going to be able to ping it.

    If you manually set your laptop IP to 192.168.1.2 255.255.255.0 or /24 and then try and ping??  You could then look in your arp table.. Do you see a mac for 192.168.1.1 ??

    example my pfsense is 192.168.9.253 with an arp -a you can see that I have a mac address for it.  Do the arp -a right after you try and ping..  If you see all zeros, or error, for 192.168.1.1 or even something other than the mac of your pfsense interface your going to have problems..

    A common issue here is your setting the WRONG interface as LAN..  You need to check the mac addresses of the interfaces on your pfsense box to make sure your setting the actual lan interface as lan..




  • Well i had a bright idea to get my GF old computer from her dads house.

    I bought a cheap ass NIC card. I just wanted to make sure that i was not getting crazy.

    Long story short. Got to the WEB GUI on the DELL PC doing the same install what i was doing all along.

    Guess my nice new M350 case with PD11BI CC2 Mitac dual does not want to play with Pf sense.

    I will try to replace it with the Intel NIC version.

    For show see the pictures.

    :o










  • P.s.

    http://mikepowells.net/2011/07/08/full-pfsense-on-embedded-hardware/

    I read here if you have problems getting past the interface assignement in pfsense because you don,t have seperate interfaces for the LAN and WAN. The option is then to setup Vlans and create 2 Vlans interfaces.

    Anybody thoughts on that ?


  • LAYER 8 Global Moderator

    do you have a smart/managed switch that supports vlans?  I thought your hardware had 2 nics?



  • My initial setup is the M350 case with MITAC board and 2 NIC i have no success with that machine.

    The big tower is a scratch computer i dig up and put a extra NIC in… this  i got to working. So i can conclude the new M350 case build has some hard ware issue.

    I think my initial setup (new build) is not doing well with Pf sense.

    I tried the Vlan interfaces setup like described in the link but same result as before.

    Its like the system does not see the interfaces as separate.

    I made a last ipconfig and arp -a see picture. Set the laptop manual IP, gateway, subnet.

    ![ipconfig and arp.jpg](/public/imported_attachments/1/ipconfig and arp.jpg)
    ![ipconfig and arp.jpg_thumb](/public/imported_attachments/1/ipconfig and arp.jpg_thumb)



  • Just another though:

    I had problems with the initial setup of the BIOS. They advice me to put it in windows 7 default mode. Put settings in "legacy" mode. Original was set top UEFI boot but i could not load from the USB. Even not when i changed to boot order.

    Could this be an issue ?


  • Banned

    UEFI won't boot indeed. You need Secure Boot disabled and "legacy" mode on. How's it called depends on your BIOS vendor.



  • I understand. But i put it on legacy mode "setting default for windows 7"  thats the setting the vendor recommended for installing pfsense due to the booting from usb issue.

    But now i am thinking can this setting causing my NIC assignment problem ? Should i go back on UEFI mode with some other tweaks.

    Its like my system cannot differ the two onboard NICs


  • Banned

    I have NFC what W7 has to do with BIOS settings, sorry. Read the motherboard manual.



  • If you use a USB 3.0 Memorystick, you can use the embedded version of pFsense.
    Download the preferred image and extract it with 7zip.
    Then use Win32 Disk Imager for extracting the .IMG file to your USB memorystick.
    That's how i use pFsense for almost 8 months now.

    Grtz
    DeLorean


  • LAYER 8 Global Moderator

    "Its like my system cannot differ the two onboard NICs"

    Nonsense – more like your just assigning them wrong... What are their Macs?  Set one to dhcp, the other lan - plug in and let get dhcp from your isp/router.. The other one is the lan..



  • Hey guys….

    Got it finally working. Before install i plugged in both network cables one from my moden and the lan. Power cycled my modem. On boot the WAN adress was present this time. Assigned the LAN ip, subnet and range etc. No problem getting to the web GUI.

    Thanks for all your feedback and posts.

    This thread can be set to solved/ close  :)


Log in to reply