RFC1483 Bridge Connectiom with Pfsense



  • I just upgraded my connection and now i have RFC1483 bridge connection and trying to make it work with pfsense is giving me a headache .
    My router config is this, i have the option to Bridge the Wan interface(right now is DHCP just to have internet through the router) i have tried but i cant get pfsense to get the public IP.
    Do i need to add some sort of rule to the WAN or disable some feature



  • I'm not that familiar with RFC 1483 connections - but what happens if you set the router to Bridge Mode and turn off any firewalling and NAT in the router, then tell pfSense to use DHCP before power cycling both the router and your pfSense installation. Note down the settings you have both in pfSense and on your router before proceeding so that you can get back to where you are now if it doesn't work out.

    RFC 1483 connections should either be able to be bridged (in which case the DSL router is just acting as a DSL to Ethernet bridge) or routed (in which case the DSL router takes an IP address and either runs its own NAT, or you let it take one of your allocated addresses if you have multiple public IP addresses).



  • I have the router working with the settings above but I have bridged it (dsl->ethernet) but pfsense dos not get an ip .
    I can allways leave it as it is and add pfsense wan ip(atibuted by router) to DMZ ,but i dont like this config .
    I rader have pfsense with the public IP.
    I spoke with my ISP tech support but they dont know if its possible bridge ,this is ADSL2+ IPoAtm ,on a speedtouch router shows EthoA ,it does not have any user nor password ,just put a compatible router  and you have internet.
    Thanks any way for the support,i'll keep trying .

    info about rfc 1483
    http://rfc.net/rfc1483.html



  • Sucess !  ;D

    I have another router (Thompson 546 v5 old one but 5*,better than some new routers out there),first had to find another firmware with the "WORLD MODE" found the 6.1.0.5(before had one from uk, but the bridged part was not ok,could not synchronize the adsl ).
    With my old router(546v5) i have 1.176 / 10.933 up/down before with the other u see above had 932/8845(old stuff rock  :D ).
    This was the easy part.

    The weird thing-if i connected my laptop to the bridged router i would get the public ip instantaneously.(Did some packet capture with Ethereal just to seen wich was the DHCP server)

    The hard part- getting pfsense to grab the public ip attributed by my isp.

    
    10.6.30.254	06/15/08 09:06:11	06/15/08 09:06:09	pfsense	system	Info	dhclient[5217]		"DHCPREQUEST on fxp0 to 255.255.255.255 port 67"
    10.6.30.254	06/15/08 09:06:09	06/15/08 09:06:07	pfsense	system	Info	dhclient[5217]		"DHCPOFFER from 77.54.192.2"
    10.6.30.254	06/15/08 09:06:09	06/15/08 09:06:07	pfsense	system	Info	dhclient[5217]		"DHCPDISCOVER on fxp0 to 255.255.255.255 port 67 interval 1"
    10.6.30.254	06/15/08 09:06:05	06/15/08 09:06:07	pfsense	system	Info		last	"message repeated 4 times"
    10.6.30.254	06/15/08 09:05:57	06/15/08 09:05:54	pfsense	system	Info	dhclient[5217]		"DHCPREQUEST on fxp0 to 255.255.255.255 port 67"
    10.6.30.254	06/15/08 09:05:55	06/15/08 09:05:52	pfsense	system	Info	dhclient[5217]		"DHCPOFFER from 77.54.192.2"
    10.6.30.254	06/15/08 09:05:55	06/15/08 09:05:52	pfsense	system	Info	dhclient[5217]		"DHCPDISCOVER on fxp0 to 255.255.255.255 port 67 interval 1"
    10.6.30.254	06/15/08 09:05:50	06/15/08 09:05:52	pfsense	system	Info		last	"message repeated 4 times"
    10.6.30.254	06/15/08 09:05:42	06/15/08 09:05:40	pfsense	system	Info	dhclient[5217]		"DHCPREQUEST on fxp0 to 255.255.255.255 port 67"
    10.6.30.254	06/15/08 09:05:40	06/15/08 09:05:38	pfsense	system	Info	dhclient[5217]		"DHCPOFFER from 77.54.192.2"
    10.6.30.254	06/15/08 09:05:40	06/15/08 09:05:38	pfsense	system	Info	dhclient[5217]		"DHCPDISCOVER on fxp0 to 255.255.255.255 port 67 interval 1"
    10.6.30.254	06/15/08 09:05:30	06/15/08 09:05:38	pfsense	system	Info		last	"message repeated 3 times"
    10.6.30.254	06/15/08 09:05:23	06/15/08 09:05:21	pfsense	system	Info	dhclient[5217]		"DHCPREQUEST on fxp0 to 255.255.255.255 port 67"
    10.6.30.254	06/15/08 09:05:21	06/15/08 09:05:19	pfsense	system	Info	dhclient[5217]		"DHCPOFFER from 77.54.192.2"
    10.6.30.254	06/15/08 09:05:21	06/15/08 09:05:19	pfsense	system	Info	dhclient[5217]		"DHCPDISCOVER on fxp0 to 255.255.255.255 port 67 interval 2"
    10.6.30.254	06/15/08 09:05:10	06/15/08 09:05:19	pfsense	system	Info		last	"message repeated 5 times"
    

    The dhcp server was responding but no ip was attributed to my WAN nic.
    Only after 10 min of this syslog it finally got an ip …

    bound to xxx.xxxx.xxx.xxx -- renewal in 1800 seconds
    

    with a 30min  lease  ??? (now that could explain allot)

    Several things  could have happened here .
    -The lease of my ips is 30 min and it does not release the ip before that time
    -In some configuration i clone the mac on the WAN if (it could have been blocked by the isp aka mac spoof)
    -Changed the MTU to 1500
    -Final but not least i did a reset to the states and after this it started to work(don't know if it was coincidence)

    Conclusion ADSL2+ RFC1483 bridged LLC works with pfsense ,just need the pacience to make it work(and 10 min of "DHCPDISCOVER on fxp0 to 255.255.255.255 port 67 interval 2"  :P)



  • I'm using the same setup, an ADSL2+ modem/router set to RFC1483 bridged llc and it has worked just fine with pfsense right from the beginning. If the bridging is done properly by the modem then you won't be able to tell the modem is even there, the connection looks like a normal ethernet connection with dhcp assigned address.



  • I had the bridging well done because i could get an ip with my laptop,but pfsense took ages to get an ip and only today i manage to do it.


Log in to reply