Problema Acesso Interno Site Empresa



  • Boa noite pessoal, primeiramente gostaria de agradecer por todo conteúdo que ja consegui encontrar aqui no forum e em poucos dias fui do nada até a aplicação do pfsense no ambiente da empresa com failover funcionando e tudo mais. Mas hoje durante o dia surgiu um problema e ja vasculhei o fórum buscando uma solução que nao encontro e gostaria de saber se alguém pode me ajudar.

    No ambiente tenho um servidor com Server 2008 R2 rodando AD+DNS+DHCP e recentemente instalei o pfsense apenas para proxy e failover dos links de internet, mas venho tendo problemas para acessar o site da empresa pela rede interna.

    dentro do DNS do Server 2008 tenho os dominios "empresa.local" e "empresa.com.br" devido alguns hosts que tiveram de ser criados para facilitar o acesso externo e interno para o openfire e webmail, mas até ai tudo bem pois quando pingo nos hosts tanto servidor quanto clientes estao respondendo corretamente e trabalhando normalmente até mesmo o outlook.

    O problema esta no acesso ao site internamente, quando voce esta fora da rede e digita www.empresa.com.br, ele carrega o site alterando para "empresa.com.br" removendo o "www" e abrindo normalmente, no ambiente interno ele efetua o mesmo processo porem não carrega a página.  Pingando da rede interna para "www.empresa.com.br" ou "empresa.com.br" ele tambem pinga normalmente.

    Ja tentei de todas as formas contornar o problema, desativando o DNS forwarder e/ou utilizar o DNS resolver criando regras de Domain override, configurei para o pfsense utilizar o proxy do server como default porem ele nao navegou, e tambem efetuei o teste de ping via ssh no pfsense e ele resolveu certo o destino do "www.empresa.com.br".

    Alguma ajuda que alguem possa me conceder?

    Obrigado!



  • alguma ideia?  :'(



  • vc continua utilizando o windows server como DNS ou mudou pro pfsense?

    também coloque uma regra de acesso direto ao site da sua empresa no proxy



  • @chipbr:

    vc continua utilizando o windows server como DNS ou mudou pro pfsense?

    também coloque uma regra de acesso direto ao site da sua empresa no proxy

    Bom dia chipbr, esqueci de citar que o proxy de momento esta desabilitado, e sim continuo utilizando o DNS o windows server sendo que o mesmo configurar os clientes pelo DHCP do windows server tambem.



  • Seu problema não me parece ser com DNS.

    Se a estação consegue receber o IP certo conforme o ponteiro Host(A), está tudo certo.

    O site em questão, está hospedado na mesma subrede das estações? Se sim, você simplesmente marca nas estações "Não utilizar proxy para endereços locais".



  • é uma intranet? ja peguei problemas parecidos e era algum javascript no próprio site que fazia o redirecionamento errado.



  • Bom dia pessoal, não o site esta hospedado em um servidor externo, pelo que o responsavel pelo site me passou esta publicado no wordpress.



  • Pelo que entendi você tem um nome de domínio interno replicando um nome de domínio externo por motivos que você entende.
    Depois que liga o proxy, na hora de resolver ele aponta todo mundo pra dentro?
    O que é estranho é o direcionamento de porta 80 se o Servidor local não tem IIS instalado e nem WAMP.
    O cenário é bem esquisito. Abre as configurações do proxy, desmarca a opção "Bypass Proxy for Private Address Destination" e testa novamente.

    Utiliza proxy transparente, certo?



  • Boa noite rafaelss, esta certo quanto ao dominio, mas no momento o proxy nao esta ativo.


Log in to reply