Squid3 -> AntiVius não inicia



  • Boa tarde a todos;

    Estou configurando um pfsense 2.2.5 com squid3 e AV, mas o antivirus nao inicia
    e sendo assim nao faz download.

    Visualizando os logs recuperei esse erro:

    ERROR squidclamav_end_of_data_handler: Can't connect to Clamd daemon.
    ERROR dconnect: Can't connect to clamd on local socket /var/run/clamav/clamd.sock.
    

    Agradeço a ajuda de todos.



  • Vá em Diagnostics > Command Promt
    Execute o comando:

    freshclam
    

    Aguarde terminar.

    Agora vá em Status > Services e inicie o serviço do ClamD manualmente. Depois que fizer isso a primeira vez, funciona normal depois.



  • Bom dia LFCavalcanti;

    Já havia tentado executar a atualização manualmente pelo ssh e o erro
    é outro, ele faz o download do "mail.cvd" até 100% por 3 vezes e da um erro:

    
    [2.2.5-RELEASE][root@pfSense.xxxxxx.xxx]/root: freshclam
    ClamAV update process started at Thu Nov 26 09:41:56 2015
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.98.6 Recommended version: 0.98.7
    DON'T PANIC! Read http://www.clamav.net/support/faq
    nonblock_recv: recv timing out (30 secs)
    WARNING: getfile: Download interrupted: Operation now in progress (IP: 168.143.19.95)
    WARNING: Can't download main.cvd from database.clamav.net
    Trying again in 5 secs...
    
    

    E no log fica com os mesmos erros anteriormente mencionados.
    E é lógico, o clamd não inicia.

    Obrigado.



  • Na interface do Web, clica em services > Squid Proxy Server e vai até a guia antivírus.
    Seleciona um Mirror (usei US) e salva. Depois clica no botão "Update AV".
    Da uns 5 minutos pra ele e depois tenta iniciar o serviço manualmente.
    Observa se ticou a caixinha do "Enable" na referida aba também.

    Abraço



  • Boa tarde;

    Já tentei isso também, com quase todos os mirrors disponíveis.
    Mas vou fazer aqui novamente.
    Posto o resultado daqui um tempo.

    Edit:
    Como eu já imaginava, o problema continua, o clamd nao inicia.
    E vejam o log:

    Algo relacionado com o processo do clamav.



  • Se você remover o Squid3 ele remove o clamav junto e quando reinstalar ele é instalado outra vez.
    Tentou isso também?
    Li uma vez sobre algumas incompatibilidades entre o Clamav e algum recurso do SquidGuard. Se eu lembrar onde li eu posto o link, explicava como contornar.
    Sempre que ativo o Squid3 antes de instalar outro pacote ajusto ele e o antivírus. Ele também é sempre o primeiro pacote que instalo.

    Chegou a dar o comando freshclam no Diagnóstics>Comando Prompt ??

    Abs



  • Opa, boa tarde;

    Pois é, já removi o squid3 e reinstalei, inclusive essa é a segunda instalação completa do pfsense
    que faço e acontece o mesmo problema, por isso suspeito de ser um erro meu e nao do sistema.
    Sobre a compatibilidade clamav + squidguard, eu tentei deixar primeiro o AV funcionando pra depois
    por o squidguard. Mesmo antes do SG já tinha problemas com o clamav.

    Sim, tanto pelo Comando Prompt quanto por conexao via shell SSH, e sempre o mesmo problema.

    Ainda estou em busca da solução.

    Obrigado.



  • @frmoronari:

    Ainda estou em busca da solução.

    Obrigado.

    Me parece que o Daemon do ClamaV não consegue se conectar aos servidores pra fazer o Download.

    Tente colocar DNS alternativo na configuração do Squid pra ver se funciona.



  • Galera,

    O Meu também não estava iniciando, ai segui os passos desses link. http://egoncalves.com.br/pfsense/pfsense-squid3-dev-clamav-i386/

    fiz esse procedimento

    1 - Fui verificando se tinha todos os diretórios e dando permissão inclusive para o diretório /var/log/clamv/freshcmd.log

    mkdir /var/log/clamav
    chmod 775 /var/log/clamav
    mkdir /var/db/clamav
    chmod 775 /var/db/clamav
    mkdir /var/run/clamav
    chmod 775 /var/run/clamav
    mkdir /var/log/clamv/freshcmd.log

    2 - no Squid 3 na aba antivírus, fiz o update através do local "US"

    3 - por ultimo segui os passos que o Lcavalcanti falou, fui em diagnostic > comand e executei Freshclam, esperei um tempo e iniciei o serviço do clamd manualmente

    ai ao acessar a aba realtime, obtive o log dizendo que mail.cv foi atualizado (version 55 f-level 60), quando fui ver, serviço iniciado!

    aqui utilizo o squid3 + squidguard

    Abraços

    Diego



  • Bom dia;

    Realizando as verificações novamente, constatei que nao existe o arquivo “clwarn.cgi”.
    Sendo assim alguem pode me passar o conteúdo deste arquivo para que eu possa cria-lo
    manualmente e realizar novos testes?

    Obrigado.



  • @frmoronari:

    Bom dia;

    Realizando as verificações novamente, constatei que nao existe o arquivo “clwarn.cgi”.
    Sendo assim alguem pode me passar o conteúdo deste arquivo para que eu possa cria-lo
    manualmente e realizar novos testes?

    Obrigado.

    Pelo que percebi..
    Nas versões de agora, não é mais esse clwarn.cgi e sim o squid_clwarn.php
    Também se encontra no caminho /usr/local/www/

    Se estou errado, por favor me corrijam.



  • Bom dia a todos;

    Não sei porque, mas o clamd iniciou:

    mas ainda nao consigo realizar o update mesmo trocando de mirror:

    Agradeço por qualquer ajuda.



  • Roda o freshclam na console com o debug ativado

    fonte:
    http://linux.die.net/man/1/freshclam

    freshclam –debug --stdout



  • @marcelloc:

    Roda o freshclam na console com o debug ativado

    fonte:
    http://linux.die.net/man/1/freshclam

    freshclam –debug --stdout

    Marcello, bom dia.

    Ontém tinha rodado o freshclam sem problema e hoje fui rodar e deu isso:

    ERROR: Incorrect argument format for option AllowSupplementaryGroups
    ERROR: Can't open/parse the config file /usr/local/etc/freshclam.conf
    
    

    Alguém sabe como resolver isso?
    Os serviços estão ativos normalmente, somente não consigo rodar o freshclam.



  • Já aproveitando o assunto.

    Notei que com o Clamav ativo, a navegação fica mais lenta.

    É normal isso?

    Tem alguma configuração a ser feita pra deixar rodando liso?



  • @marcelloc:

    Roda o freshclam na console com o debug ativado

    fonte:
    http://linux.die.net/man/1/freshclam

    freshclam –debug --stdout

    Boa tarde;

    Como solicitado pelo marceloc executei o freshclam –degub --stdout no console (via ssh)
    e após rodar por 3 vezes, realizando o download até o final as 3 vezes ele retorna o mesmo erro
    e por final indica um possivel erro nos mirros:

    
    [2.2.5-RELEASE][root@pfSense.XXXX.XXX]/root: freshclam --debug --stdout
    ClamAV update process started at Tue Dec  1 14:11:01 2015
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.98.6 Recommended version: 0.98.7
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
    nonblock_recv: recv timing out (30 secs)
    WARNING: getfile: Download interrupted: Operation now in progress (IP: 66.18.18.59)
    WARNING: Can't download daily.cvd from db.us.clamav.net
    Trying again in 5 secs...
    ClamAV update process started at Tue Dec  1 14:11:56 2015
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.98.6 Recommended version: 0.98.7
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
    nonblock_recv: recv timing out (30 secs)
    WARNING: getfile: Download interrupted: Operation now in progress (IP: 207.57.106.31)
    WARNING: Can't download daily.cvd from db.us.clamav.net
    Trying again in 5 secs...
    ClamAV update process started at Tue Dec  1 14:12:54 2015
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.98.6 Recommended version: 0.98.7
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
    nonblock_recv: recv timing out (30 secs)
    ERROR: getfile: Download interrupted: Operation now in progress (IP: 150.214.142.197)
    ERROR: Can't download daily.cvd from db.us.clamav.net
    Giving up on db.us.clamav.net...
    ClamAV update process started at Tue Dec  1 14:13:43 2015
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.98.6 Recommended version: 0.98.7
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
    Trying host database.clamav.net (198.148.78.4)...
    nonblock_recv: recv timing out (30 secs)
    ERROR: getfile: Download interrupted: Operation now in progress (IP: 198.148.78.4)
    ERROR: Can't download daily.cvd from database.clamav.net
    Giving up on database.clamav.net...
    Update failed. Your network may be down or none of the mirrors listed in /usr/local/etc/freshclam.conf is working. Check http://www.clamav.net/doc/mirrors-faq.html for possible reasons.
    
    

    Esses erros já eram obtidos antes, dessa mesma forma. Faz o download 3 vezes e acusa erro no mirror.
    Continuo na mesma.

    Obrigado pelas ajudas.



  • ERROR: getfile: Download interrupted: Operation now in progress (IP: 198.148.78.4)
    ERROR: Can't download daily.cvd from database.clamav.net
    

    Esse erro,  indica problema de conectividade(placa de rede, cabo, link, outro fw na frente, rotas, etc…)



  • Boa tarde;

    Pois é marcelloc, o problema que é que seu for em um desktop e realizar o download
    do arquivo eu consigo baixar sem nenhum problema.

    E por isso eu penso ser algum problema de configuração no pfsense.

    Ainda testando.


Log in to reply