Boot errors efter upgrade ?



  • Hi guys, after upgrade to 2.2.5 it takes unusual long time for boot.
    20minutes for full boot up.
    Ok, to be completely honest, im not sure is this upgrade related problem, because i didnt reboot machine for months.

    Machine is about 5 1/2 years old (hdd operating time 1930days +)
    AMD Athlon™ 64 X2 Dual Core Processor 6000+
    2 CPUs: 1 package(s) x 2 core(s)
    4GB ram
    RAID 10

    this is error i get on boot
    Nov 26 08:10:52 router-one kernel: ahcich3: is 00000000 cs 00000000 ss 00000000 rs 00000001 tfd 50 serr 00000000 cmd 00048017
    Nov 26 08:10:52 router-one kernel: (aprobe0:ahcich3:0:0:0): SETFEATURES SET TRANSFER MODE. ACB: ef 03 00 00 00 40 00 00 00 00 44 00
    Nov 26 08:10:52 router-one kernel: (aprobe0:ahcich3:0:0:0): CAM status: Command timeout
    Nov 26 08:10:52 router-one kernel: (aprobe0:ahcich3:0:0:0): Retrying command
    Nov 26 08:10:52 router-one kernel: ahcich3: Timeout on slot 0 port 0

    log is attached

    BIOS options, USB, firewire 1394, audio etc, all turned off

    it seems this is HDD related error? is it?

    thanks

    [boot log.txt](/public/imported_attachments/1/boot log.txt)



  • Probably a HD issue as you suspect.

    Simplest thing to try is copy the config.xml off that drive and reinstall on a different HD, then restore the config.xml.
    Shouldn't be more than 25 min's (if you make a cup of coffee as well…..)



  • The device that's erroring out there is the DVD-RW. It's not replying initially, though seems to get over itself eventually, unless the OS is just giving up on it. That didn't change from upgrading. Drive probably flaked out since your last reboot.



  • 2 CMB
    thank you,
    you where right it was CD RW problem.
    i just unplug it and machine boots fast as before with no errors. (tried with new CDRW, boots perfectly)

    Either way, while machine is out of order, it is time for hdd change and cdrw change, ram upgrade etc. ;)

    i know it is not topic related but,
    after 2.2.5 install on new machine, and installing squid3 and than squid guard,
    squid 3 seems to work, but when i enable squidguard, squid seems to stop working, machine slows down to almost unusable device, and i cant disable squidguard.

    When i disable squidguard (Proxy filter SquidGuard: General settings)

    • general settings tab
      –- enable (unchecked)
      apply takes about 10 minutes and it does not disable squidguard (status - services it is up), and squidguard is still running.
      only thing that can be done is reboot

    i tried to reinstall squid3 than squidguard, and  squidguard than squid3, but same thing happens.

    do you maybe have idea what is happening?

    thanks


  • Banned

    @josey:

    i know it is not topic related but,

    https://forum.pfsense.org/index.php?board=60.0



  • update
    after testing it seems it is update issue.

    i tried to make fresh install on vr 2.2.5
    and during boot i get same error as from first post.
    Change couple of cd / dvd drives, same thing every time.

    With usb memory key it boot up to installer, but instaler does not see raid on mainboard, it sees only 2x hdd.

    i thought, it seems all my cd/dvd drives are screwed up, and then i tried with vr 2.0,
    and it boots from cd and installer sees raid.
    no errors at all.

    this is freebsd drivers related?
    suggestions?

    thanks



  • update,
    i found solution how to eliminate boot up errors regarding ahcich xx.
    on installed PFS add
    "hint.ahci.0.msi=0"
    to /boot/loader.conf

    if you have problems during fresh install
    hit "3" escape to loader prompt and type
    "set hint.ahci.0.msi=0
    boot"

    however i had no success adding nvidia raid controller to pfs 2.2.5 installer (attached)

    while pfs 2.0 installer sees it (attached)

    I tried with set kern.geom.raid.enable=1,
    add drive and mirror drive with no errors, but geom raid does not appear as option in disk selection to instal PFS.

    do you have any suggestions?

    edit:
    https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201194

    ![pfs 2.0 installer.JPG](/public/imported_attachments/1/pfs 2.0 installer.JPG)
    ![pfs 2.0 installer.JPG_thumb](/public/imported_attachments/1/pfs 2.0 installer.JPG_thumb)


Log in to reply