Can't get IPv6 on LAN



  • Hello,

    My pfSense box has problems with IPv6 since 2.2.3 or so. (First version i've ever tried)

    My IPv6 only works in the WAN interface, and in the pfSense itself. It doesn't hand over IPv6 Addresses to my devices. I've tried everything already.

    Here's my current config for IPv6

    WAN INTERFACE

    LAN INTERFACE

    Overview

    Radvd logs



  • Your setup looks right, but I don't think your ISP is handing out prefixes.

    Another poster had a similar issue, also in 2804:14c:: prefix, which all seems to point back to Grupo de Segurança Vírtua (virtua.com.br).
    I'm guessing they aren't quite ready for IPv6 in production.

    Get a free HE.NET IPv6 tunnel service here: https://tunnelbroker.net/, with a free /48 prefix.
    Save yourself the headaches until your ISP can get their network sorted out.



  • Just another screenshot, to make sure.

    Is that really it? Cause I can request the prefix if I want.



  • You got an IPv6 address on the WAN side, but that won't do any good unless you also get an IPv6 address from a different prefix on the LAN side.
    It looks as if the ISP isn't honoring the IPv6 prefix delegation request.


Log in to reply