LACP Flapping



  • Hi all,

    I used four ports to build a port-channel (lagg0) and connect to cisco switch 2960-g. The lgg0 will show a error message "igbX: interface stopped Distributing, possible flapping" when a very very high traffic incoming. I tried to disable the strict mode in Pfsense, but  it cannot solve my issue.

    My pfsense OS version is: 2.2.5

    Do you have any good suggestions for me?



  • What brand/model are the NIC(s) you currently use?



  • Hi,

    My NIC is Intel® 82580 Gigabit Ethernet Controller Family (Quad port).

    Thanks



  • when a very very high traffic incoming. I tried to disable the strict mode in Pfsense, but  it cannot solve my issue.

    Perhaps it is here more the thing on the knowledge, how LAGs are working and in which mode they are working
    how. There are two different LAG modes are out, not more and not less.

    • Dynamic LAGs using the LACP (Link aggregation control protocol) for an automatic configuration
    • Static LAG using not the LACP and all must be manually configured absolutely identically on both sides!

    The LAG (LACP) is is working likes this: If two cables or Ports are used, the first Port will be filled up to 100%
    and then first the next one will be beginning to fill with packets.

    The static LAG will be able to allow to use the weighted round robin method and all ports will be filled
    with data at the same time.

    Do you have any good suggestions for me?

    So you might be using in your case, pending on the very very high traffic incoming, more the static one
    and chose the weighted round robin method, to fill the port all together step by step!

    Either method you are using they all must be choosing active/active and not active/passive!!!!
    this is important for both methods, because if you are going the active/passive way, only the first
    port and line will be used and if this is full the next one will be enabled and will be used, but going
    the active/active way, all ports from the first beginning will be used in this case.



  • Thank you for your suggestions.

    Would you mind teaching me how to set Active/Active or Active/passive in pfsense?



  • @BlueKobold:

    The LAG (LACP) is is working likes this: If two cables or Ports are used, the first Port will be filled up to 100%
    and then first the next one will be beginning to fill with packets.

    The static LAG will be able to allow to use the weighted round robin method and all ports will be filled
    with data at the same time.

    Won't both of those implementations cause out of order packets? Once of the first things I read about LACP from years ago is L2 or even L3 or L4 hashing, and load-balancing on the hash, which doesn't cause OoO packets.



  • @tomli:

    Thank you for your suggestions.

    Would you mind teaching me how to set Active/Active or Active/passive in pfsense?

    No I can´t do so, sorry. I was using LAGs for a short time, but not together with pfSense, than I switched over to
    10 GBit/s thats more efficient and more reliable and stable. In shorter words, there are two modes and one is using
    all lines of the aggregated line and the other modes is using only one line and if this line is full the next one will be
    begin to use. And they are also two different ways you can walk this road, one is automatic over the LACP with
    dynamic LAGs and the other is the manual way using static LAGs and you will be able to choose the method by
    your own to balance this out over more line at the same time. I was using even static LAGs, active/active and
    together with the "weighted round robin" method, to fill all lines constantly. So I was thinking if there is now
    something likes you were reporting likes port flapping or packet drops it would be perhaps the problem of the
    active/passive usage of the LAG.


Log in to reply