Satellite Broadband Problem



  • OK, I'm going to try to lay this all out without being confusing.

    I'm running a satellite broadband site, and trying to change from a Linksys WRT54G (running DD-WRT) router to a pfSense box.  I want to use many of the features pfSense has to offer on my network (traffic shaping, captive portal, bandwidth logging, web caching, ect).  However, I'm unable to get the pfSense box to resolve DNS through the sat modem (at least, thats what I think the problem is ??? ).

    My sat modem is set to the ip 10.144.0.97, with my IP range being .98-.110, subnet 255.255.255.240 (or /28 in pf-speak).  When I have the WAN configured to 'static', these settings entered and 10.144.0.97 entered as the default gateway, I can ping the modem from the ping tool in pfSense.  So I know the pf box and the sat box should be able to communicate.  On the LAN side, I had some detailed settings set up, but still wasn't getting any connection to the internet.

    I just did a 'reset to defaults' on the whole pf box, it's still not working.  I'm really out of ideas.  I've got two DNS servers that I'm supposed to use, they're entered in the 'general setup' tab, and I've also tried Verison's DNS servers (4.2.2.3 and 4.2.2.4), with no luck there either.  My linksys router works fine on 10.144.0.98, the pf box is setup as .99 right now.  I tried unplugging the linksys and setting the pf box to .98, I figured maybe my provider locked the IP's I wasn't using.  No luck there either, the pf box still got no connection.  I unplugged it and plugged the linksys back in, it's happily humming away again.  I'm pretty sure a ping on the WAN side confirms that NIC is good, so I really don't know where the fault lies.  The Linksys is using the same two DNS servers that I've put into the pf box with no issues . . .

    Anyone have any ideas I should try?  I'm stumped  :'(



  • One one of the settings pages (I don't remember which) there's a box that, when ticked, blocks access to the RFC1918 addresses (such as the 10.x ranges).  Make sure that's not ticked.



  • It's under the individual interface tabs, and it is checked by default.

    Thanks very much, this fixed the problem nicely.  I don't understand how I could ping the modem with this checked though?

    Anyway, it's working now.  Installing Squid as we speak, and I'll go from there.  Thanks for the help, I really appreciate it!


Log in to reply