2.2.5 tftp proxy broken



  • I have a 2.1.3 system where this scenario works fine:

    Phones @ LAN
    PBX/tftp @ WAN
    System > Advanced > Firewall > NAT > TFTP Proxy > LAN+WAN both selected.

    This feature appears to be broken in 2.2.4 -2.2.5, requests go out and hit the tftp server, but the replies never get back in to the phone.

    I have also tried static NAT rules for outbound udp traffic, anyoen else see this issue?



  • I didn't see an issue on 2.2.4 but that could be because I didn't reboot my phone. Now I'm on 2.2.5 and I get

    tftp-proxy[59409]: couldn't forward tftp packet: Operation not permitted

    Also I have noticed that when I select Services - TFTP. I get a 404 error.

    I have just moved to a static WAN IP so this maybe caused by me but thought I would let you know

    Hass



  • Just an update looks like upgrading to 2.2.5 broke the TFTP package a re-install fixed that but I still get the error on the FTFP client. I'll let you know if I work it out



  • Mine was a fresh brand new install, so you are saying you did the same and it works now?

    But it sounds to me like you are using the tftp package addon… Not the built in proxy??? The addon package would be the one under Services, and it loads a local tftp server on the firewall where you can store files.

    The proxy is under System > Advanced > Firewall > NAT > TFTP Proxy This assumes an inside or outside tftp server with devices trying to get to it from the other side.


  • Banned

    Yeah indeed the package and the proxy are two completely different things.


Log in to reply