Why does my new install freeze?



  • Hi

    I have been having a problem for the last few weeks that has been making me go a little crazy as I can't see an underlining issue.

    I have a full VmWare Vsphere setup with quite a few VMs, virtual switches and other standard items.

    There is a Pfsense box in one subnet on one virtual switch, connected to another (it provides NAT) - no issues, works as expected.

    I created another Pfsense box in another subnet on a different virtual switch - again, no issue, works as expected.

    I then wanted to create another Pfsense box in the same subnet/same virtual switch as the one above, but, I just haven't been able to and I can't understand why.

    The virtual hardware is identical, and the install goes fine, but, after first boot where it asks me to assign the interfaces (or, it doesn't ask if it is a new VM with two NICs), it seems to get slower and slower and eventually freeze.

    I noticed this happens very often straight after choosing option 2 off the menu, but it seems to gradually happen anyway.

    I showed this to a friend and after several reboots, he managed to quickly go in and install the open-vm-tools package, and it hasn't frozen since.

    Anyway, the second Pfsense box I had didn't have this package and it didn't freeze, and I haven't had this problem before.

    I've tried creating additional boxes/resetting and it keeps happening.

    I'm glad that using the Vmware tools seems to fix it, but, I just can't understand why/what is happening. Whilst I am guessing this isn't an issue directly with Pfsense (as the other boxes work), I would appreciate some help in identifying the issue. Has anyone seen this before or does anyone know what I should try next?



  • To add to the previous post,

    I've been trying various things on and off tonight, and, it just confuses the hell out of me.

    The box has a public IP, and it can ping the gateway and internet sites.

    Machines on the same subnet, and from the internet can not ping it, or access the admin page.

    It seems to freeze after about 2 minutes, but this is random.



  • What version of ESXi are you using?  I've run pfSense on 5.1, 5.5 and 6.0 without any problems, and no open-vm-tools.  Just plain old E1000 NICs for the most part.



  • It is ESX 5.5.

    And yep - first install was multiple NICs, E1000, with tools - worked perfectly.
    Second install was a single E1000 Nic, no tools - worked perfectly.

    Every extra install I do now just seems to freeze and I just don't know what to do next!

    There is ample capacity on the hosts, I am using the same config as the second VM, and same media for the install - I just can't work out what is wrong!

    Every time it is the same - the machine gets slower and slower (a few times, if I ping 8.8.8.8 - you can see the responses get slower and slower - (from ~<.5ms to 3s), then I get responses out of sync and it stops. Other times, it just freezes at the menu - I can push multiple menu buttons and see nothing. If I go back to the VM after a few minutes, all the numbers have been typed out, but the machine is as good as frozen.

    I have recreated this VM quite a few times now and I get the same result each time.

    I will try to record a video shortly - it will obviously contain a bit of sensitive info, but, it isn't really anything that people can't find out anyway…



  • Is it always on this one physical host or do you have other hosts you can try?  What's the make of the physical NIC in the host?  Anything in the System log when this is happening?  Do you have any extra packages installed?



  • Hi Kom,

    I have a Vsphere environment with 4 hosts, I deploy to the DC rather than an individual host, however, I have now recreated this several times and I have noticed it being deployed to at least 2 different ones.

    No extra packages installed, and, I tried looking in the system log, but I couldn't find anything relevant.

    It is a Dell C6100 4 node box, I can't be certain off the top of my head, but looking at Vsphere hardware monitor, it looks like it has 6x Intel 82576. I know it has the built in 2, and 4x on one adapter (per node).

    As I said before, the thing that drives me mad is that I have deployed other ones that have gone perfectly well!

    Please see the youtube video:

    Youtube Video

    In this environment, the gateway is firewalled - At about 6:20, I made a mistake - I forgot to allow ping from the temp IP I assigned the box, so, I went off screen to do that. However, when I went back to the VM, it was frozen, so I had to restart.

    I am certain I am wrong, but, my first gut feeling was that maybe something is wrong with VMWare itself - it seems to freeze when I go back to the console. But, that doesn't explain why I can't ping the box or access the GUI straight after an install (and it has also frozen in the past whilst using it).



  • I'm wondering if .33 blocks pings, and the pfSense gateway monitor may be getting screwed up by it?  Just for laughs, you could try disabling gateway monitoring in System - Routes (I think, going from memory) and see if that makes any difference.



  • Hi Kom,

    Thanks for that… I can't get on the GUI to do that! ... how would I do it from the command line?

    That being said, it is set to allow now (temporarily), and, I never had this issue on the other boxes I built.

    ... I'm going to try to download another ISO, I feel silly/doubt it can be that as it is the same one I built the second box from, but, I want to make sure nothing is corrupt.



  • I have no idea how to disable gateway monitoring from command line.



  • I don't suppose anyone else has any suggestions before this post gets lost?!



  • After cross posting this to reddit, someone responded with advise that seemed to push this along.

    Pressing the scroll lock key seemed to unfreeze the display and it would accept input again!

    I've still got an issue where I can ping out from the console and can't access the GUI, but, at least I am now further along!

    I would be curious to know why I need to press Scroll Lock and what is happening to cause this?



  • Sounds like scroll lock gets enabled within the VM somehow. If you'd hit the up arrow before turning scroll lock back off, it'd scroll up the console.

    On older ESX versions in particular (though may be applicable to all), one thing to watch out for is not having a disconnected virtual CD drive. Either connect it (just set to 'client device' is fine), or remove the drive from the VM.


Log in to reply