LAGG question



  • Hi all,
    On my board (http://www.supermicro.com/products/motherboard/Atom/X10/A1SRi-2758F.cfm)
    wan is on pci-express and the other 4 are 2 x 2 grouped in LAGG.
    igb3 + igb1 = LAGG 1 -> LAN switch(microtik)
    igb2 + igb0 = LAGG 2 -> NAS (Thecus)
    Problem is On LAGG 2 i'm not able to make thecus work with lacp in pfsense.
    both sides use 802.3ad protocol. http://blog.thecus.com/link-aggregation/
    On the Pfsense side, after creating the LAGG, on the interface tab, i just enable it without assigning any ip (v4 or v6).
    Do i miss something in configuration? cz i have no ping from pfsense to nas

    And i also got some errors in logs:
    Dec 13 03:25:48 php-fpm[51895]: /rc.linkup: Hotplug event detected for STORAGE(opt1) but ignoring since interface is configured with static IP ( )
    Dec 13 03:25:50 php-fpm[49344]: /rc.filter_configure_sync: New alert found: PF was wedged/busy and has been reset.
    Dec 13 03:25:50 php-fpm[49344]: /rc.filter_configure_sync: New alert found: There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy - The line in question reads [0]:

    Thank you.



  • why would you expect to be able to ping if you don't set an interface ip?

    this smells like an attempt to use pfsense as a switch … this has been repeated over and over and over : DONT use a pc as a switch: it works like shit and is expensive.



  • indeed i wanted to use pfsense as switch :)
    not sure if it will work with normal cable.will give it an ip and see.



  • if you really want to go ahead, while you know its a bad idea: https://doc.pfsense.org/index.php/Interface_Bridges



  • igb3 + igb1 = LAGG 1 -> LAN switch(microtik)
    igb2 + igb0 = LAGG 2 -> NAS (Thecus)

    Why? Are you using also VLANs in this scenario?
    Did you try out changing the ports to the following?
    igb0 + igb1
    igb2 + igb3

    Because this are LAN pairs and the bypass function should also be disabled in the BIOS settings.
    Why not connecting the NAS over a LAG (LACP) to the Switch and then the pfSense box also over
    LAG (LACP) to the Switch?

    You could either try out to get a cheap or refurbished Cisco SG300 series Layer3 Switch that is capable
    to route between the devices and/or the VLANs if there are some in use. So only a LAG (LACP) between
    the NAS and the Switch must be realized.

    Or alternatively go and buy a D-Link DGS1510-20 Layer3 Switch with two 10 GBit/s SFP+ ports that will
    speeding up many things better then building multiple LAGs.



  • thx for the answer.
    Now i have:
    WAN –--> PFsense ----2x Gbit----> Microtik switch RB2011UiAS ------2x Gbit-----------> NAS



  • WAN –--> PFsense ----2x Gbit----> Microtik switch RB2011UiAS –----2x Gbit-----------> NAS

    Uhm, so why you were not telling this at first? It is not a switch it is a router with a so called default
    configuration and makes on one port by default NAT! So this could also be the failure in your set up!



  • Mikrotik acts like a switch now(they call it bridge) . And works fine. I just wanna bypass mikrotik and directly connect NAS lagg to Pfsense, and use the same subnet.



  • tried several times…any kinda of setup...is not working.
    i just need igbx+igby in LACP to communicate with the NAS in lacp....well is not working.with or without ip...still no ping.
    any clue?



  • Mikrotik acts like a switch now(they call it bridge).

    Bridging ports together will ain't more problems then it help and not only tended to MikroTik routers.

    any clue?

    The cheapest Switch I know that is supporting LAG (LACP) is the Netgear GS108Tv2 (GS108T-200GES)
    you could try out to get one and connect the pfSense box and the NAS over a LAG (LACP) to it.

    It is a real Switch and not bridged ports from a router, this will driving you not nuts and
    no port flapping, no packet loss and no connection loosing or break.


Log in to reply