Slow DNS resolving, has only been happening since last night?



  • I've had pfsense for about a week now.

    I also have a wireless AP running tomato.

    Well ever since last night, I've been having slow internet loading times.

    When I run a speedtest, my reuslts are 10ms ping 60 download 9 upload. I get these results concurrently on any device I run them on.

    However, the test itself actually takes like 7-8 seconds to start.

    Also, it takes about 7 or 8 seconds for a youtube video to initialize on any of my devices.

    Lastly, when I open the google play store on my phone, it also takes about 6 seconds for all of the apps to load in.

    I'm not very smart with networking, but I have a strong feeling this is a DNS issue.

    So I tried to fix it. on pfsense I originally had "overwrite dns from WAN"
    So I was using my ISPs DNS servers.

    I unchcked that setting and now I'm using 8.8.8.8 and a dns from opendns.
    The issue is still present.

    Out of frustration, I did a factory reset of my pfsesne box and on my AP but the problem still persists.

    This only started happening yesterday. I never had this issue before.

    The only thing I did yesterday regarding my network was that I downloaded shallas blacklist for ads and put them on my ACL. But now squid and the blacklist is gone because I factory reset and uninstalled squid.

    Yet the problem still exists. How do I fix this?

    edit:

    I erased my hard drive completely and reinstalled pfsense.
    Its still happening.
    Is pfsense slowing down my connection? I dont get it.
    This wasnt happening yesterday. But even with a clean install it still happens.


  • LAYER 8 Global Moderator

    You do understand on a clean install of pfsense it uses resolver right..  If you think it is dns problem why don't you just do a simple query and see how long it takes to look up stuff…  nslookup on windows, or dig or drill or host there are lots of tools to do a simple dns query and see how long it took.

    Under diag there is dns lookup...  Look up some sites in there, what is it showing your using for dns.. Out of the box default should only show 127.0.0.1

    example - see attached.

    Does your issues only happen wireless or both wired as well?  You have AP running tomato.. And this is running as true AP, or is it doing nat as well?




  • The issue happens on wired and wireless.

    I disabled NAT on my AP.



  • 22ms is reasonable.  Not blazing, but certainly not anything you are going to humanly perceive as being slow.

    So if DNS is the cause of the slowness then it is on the local side.



  • Well it happens on all of my devices. Its a 7 second delay with everything when it never used to be like that.
    Does that limit it to my AP?



  • @kicker892:

    Well it happens on all of my devices. Its a 7 second delay with everything when it never used to be like that.
    Does that limit it to my AP?

    There is not enough info available yet to say.

    Gather some info using the tools John mentioned to do some queries from a client that has the slowness problem.

    Also what DNS server address is being assigned to the clients?



  • The clients get assigned 10.12.1.1 as the DNS



  • @kicker892:

    The clients get assigned 10.12.1.1 as the DNS

    Is that the pfSense router or the AP or other?



  • Pfsense


Log in to reply