Problem with Ntop and WinSCP



  • I just upgraded to .93.  I used the upgrade option.  And I am not sure if this is to do with the fact I just upgraded or not so I'm posting it here.

    I have just switched from monitoring fxp0 instead of xl0 in ntop as I swapped which NICs  my LAN and Wan were connected to.  For some reason I uninstalled ntop and reinstalled it.  Under pluggins when I enable rrd pluggin I get an error … which shows in the logs as below.

    ntop[887]: ERROR RRD: Disabled - unable to create directory (err 13, /var/db/ntop/rrd/graphics)

    When uninstalling and reinstalling it keeps all my settings so I wasn't able to reset it to defaults and clean all the old crap out.  So I was just going to use WinSCP to go in manually and delete everything.  As I don't know how to use the BSD shell.

    I haven't used Win SCP since .87 (i then upgraded to .90 then .93) via the upgrade patches.  It used to work but no it returns the error below.

    ""Received too large (170535466 B) SFTP packet. Max supported packet size is 102400 B.
    The error is typically caused by message printed from startup script (like .profile). The message may start with "0x0A2A2A2A".""

    I can use putty to scp in.  So I don't know why I can't connect and view the files.

    No big deal,  I can always start again and download the full install,  it just takes me forever to remember all the settings and stuff.  But if anyone has some quick fixes that would be sweet.



  • Fixed the NTOP error in CVS.

    When using WinSCP, logon as root instead of admin.

    Also make sure you have SFTP (allow SCP fallaback) selected.



  • Thanks root worked.  I did search!

    So did I find a bug? with the Ntop thing?

    Sorry I'm a bit usless.

    I edited the XML file  /usr/local/pkg/ntop.xml

    But I am not sure how to make it "work".  When I reinstalled ntop if overwrote this file.  I was browsing for ages trying to find the "master" file.

    Sorry aagain :), I'm slowly learning how to do it for myself.


Log in to reply