NAT not working, already used search



  • First sorry for my english.

    I have recently disabled nat on my router to config it as a modem so I can use a PC on my network with a PFsense to filter, nat, dhcp,….

    I already configured correctly (i supose) Pfsense, becouse i can play online games, use firefox,... but the problem comes with NAT and tried stuff of the wiki about static route.
    Lets say my wan interface(pfsense) is configured like:
    IP: xxx.xxx.xxx.47 (my internet static ip if router working with nat)
    Mask: 255.255.255.192
    Gateway: xxx.xxx.xxx.2 (was my public gateway, if router working with nat)
    My Lan interface:
    IP: 192.168.10.2
    Mask:255.255.255.0

    NAT config on pfsense:
    Nat outbound on manual mode with the automatic rule created.
    WAN /// 192.168.10.0/24 /// * /// * /// * /// * /// * /// NO

    I tried to forward external port 8000 to my local terminal server (3389) on NAT:
    WAN /// tcp/udp /// 8000 /// 192.168.10.80(ext:any) /// 3389
    (with automatic rule created on WAN interface)

    Wan interface:
    TCP/UDP /// * /// * /// 192.168.10.80 /// 3389 /// *

    Lan Interface:

    • /// Lan Net /// * /// * /// * /// *

    All seems OK becouse i can use correctly internet on all my computers, but NAT is not working. Already tried activating static port on outbound rule of NAT.

    If need more info, explanation or screen let me know pls.

    Thx for your time :)



  • no one? or something i can try?



  • What do you mean "NAT is not working"?  It's obviously working or you wouldn't have Internet connectivity. You mean the port forward? If so, see: http://doc.pfsense.org/index.php?title=Port_Forward_Troubleshooting



  • Ups! seems i explained bad, well i focused on Pfsense NAT problem but yes is port forwarding what isnt working

    My english is not good enought, let me try to explain again :)

    If I config my router to work like a modem, so my public static IP becomes the WAN IP of PFsense and the ROUTER lan IP becomes my default gateway to ISP. (dont know the word in english to define this). And Pfsense lan as a 192.168.10.0/24 network with DCHP service of Pfsense

    All work becouse i can use internet from any PC on my LAN, download mail,… but Pfsense port forward wont work. I create rules as simple as i posted and dont work.

    The objective of all this is disable NAT from my Linksys router, and control NAT, dhcp, port forward trough Pfsense. So router works like just a modem and hard work goes to Pfsense.



  • I had tried all of that link i found on another post.

    Forward rule is OK

    Reflection: tried with this option enabled before creating rules and didnt worked, reinstalled pfsense and tried again with this option disabled and still doesnt work.

    Enabled log on the rule automitcally created by NAT forward rule, and log dont show anything.

    With local IP i can acces, with publicip:port wont work.



  • This has nothing to do with your problem.
    Are you sure your modem has no firewall ability?

    You describe it a bit like the halfbridged modems.
    The modem does the PPPoE authentication, but you get a public IP on the client behind the modem.

    Check that the modem really forwards all ports to pfSense..



  • Becouse i want to disable NAT on router, maybe all port forwarding to pfsense wan interface wont make sense.
    If helps:











Log in to reply