XMLRPC Sync failing after password change



  • Hi,

    So I recently changed the admin password on my pfSense cluster, first on the master and then went to slave to change it there as well but it has already been synced across and I was able to log into the slave with the new password already.

    I updated the password in the XMLRPC sync config on the master to reflect the change but ever since have been receiving alerts stating that XMLRPC sync communication has failed with the username admin.

    I have logged onto the slave and put the new admin password in the user manually just in case but to no avail.

    A communications error occurred while attempting XMLRPC sync with username admin https://192.168.1.2:443.

    Has anyone seen this behaviour before? I am running 2.2.4, due an update or 2 I know but I would prefer to get to the bottom of this sync issue. Its only a simple password change I done?

    Tom



  • The error appears to have changed, but I still can't reach the GUI of the slave. No DRAC on the box either so its going to have to be a visit.

    Error attached.

    EDIT:

    Ok so I have been a complete moron and didn't realise that pfBlockerNG has its own settings for sync options and I hadn't changed the password in there. I have changed it now, but I am still getting errors, log is as follows but I guess this is probably because the webGUI on the slave is unavailable?

    Dec 26 12:50:01 php-fpm[40367]: [pfBlockerNG] XMLRPC sync is starting.
    Dec 26 12:51:16 php-fpm[40367]: /pkg_edit.php: XML_RPC_Client: Connection to RPC server 192.168.1.2:443 failed. Operation timed out 103
    Dec 26 12:51:16 php-fpm[40367]: /pkg_edit.php: [pfBlockerNG] XMLRPC communications error occurred while attempting sync with https://192.168.1.2:443.
    Dec 26 12:51:16 php-fpm[40367]: /pkg_edit.php: New alert found:
    Dec 26 12:51:17 php-fpm[84400]: /rc.filter_synchronize: XML_RPC_Client: Connection to RPC server 192.168.1.2:443 failed. Operation timed out 103
    Dec 26 12:51:17 php-fpm[84400]: /rc.filter_synchronize: A communications error occurred while attempting XMLRPC sync with username admin https://192.168.1.2:443.
    Dec 26 12:51:17 php-fpm[84400]: /rc.filter_synchronize: New alert found: A communications error occurred while attempting XMLRPC sync with username admin https://192.168.1.2:443.
    Dec 26 12:51:17 php-fpm[84400]: /rc.filter_synchronize: Message sent to ### OK
    Dec 26 12:51:18 php-fpm[86605]: /rc.filter_synchronize: XML_RPC_Client: Connection to RPC server 192.168.1.2:443 failed. Operation timed out 103
    Dec 26 12:51:18 php-fpm[86605]: /rc.filter_synchronize: A communications error occurred while attempting XMLRPC sync with username admin https://192.168.1.2:443.
    Dec 26 12:51:18 php-fpm[86605]: /rc.filter_synchronize: New alert found: A communications error occurred while attempting XMLRPC sync with username admin https://192.168.1.2:443.




  • Ok so I got to the datacenter and restarted the webconfigurator on the slave which seemed to sort things out for a short period of time. However this morning, the web UI on the slave has failed again and I am getting sync errors again.

    I will go and do a full restart of the slave today but failing that, what else can I look at or do without having to do a full rebuild?


Log in to reply