CPU usage very low



  • System specs:

    I never see my CPU usage more then 3%, it is usally at 0% even if downloading or uploading a big file.  Under System Activity my CPUs are always very high on the idle.

    Why is it doing this and not working harder to process?  on speedtest.net i went from 120Mb down to 4Mb down… streaming video like on Cruncyroll is not possible...  I uninstalled all squid, and disabled snort, still no change.  only service running is the firewall.

    I already set kern.ipc.nmbclusters = 1000000

    why is it sucking?! lol



  • you probably have a different issue. need more info to go on.



  • Do you have traffic shaper enabled?



  • Never EVER EVER just install a bunch of stuff without first measuring performance out of the box. Always get a baseline reading before you start making lots of changes.



  • @Harvy66:

    Never EVER EVER just install a bunch of stuff without first measuring performance out of the box. Always get a baseline reading before you start making lots of changes.

    yeah kind of what I did to resolve my issue relates to this in my trouble shooting steps.

    So basically I did the Factory Default reset, made my few changes without any package installed, tested my connection with speedtest.net and a couple streaming sites and my connection was screaming as it should, 127MB down 10MB up and no streaming issues.

    I installed Squid3 and Snort, and configured but did not turn any of them on.  Again tested my connections, and screaming speeds again.

    Now I just started Squid Proxy from Squid3, restarted, and good still screaming speeds.  So from here I am going to let this run with just Squid Proxy running for a few days and see how it is.  If no issues, then il turn on Snort.



  • System specs:

    Please remember this is not a Intel Atom (Rangeley) platform, it is a Intel Atom (Avoton) SoC!

    • Rangeley = AES-NI & Intel QuickAssist
    • Avoton = AES-NI & TurboBoost
      So enable PowerD (hi adaptive) is a must be on that platform as i see it right.
    • 64GB SSD

    Activating TRIM would be fine, if you use the Squid proxy also for caching.

    I never see my CPU usage more then 3%, it is usally at 0% even if downloading or uploading a big file.  Under System Activity my CPUs are always very high on the idle.

    This might be related to the missing PowerD option that scales the CPU right on much load and also
    if there will be no load.

    Why is it doing this and not working harder to process?  on speedtest.net i went from 120Mb down to 4Mb down… streaming video like on Cruncyroll is not possible...  I uninstalled all squid, and disabled snort, still no change.  only service running is the firewall.

    For Squid and streaming portals, some peers can be set up.

    I already set kern.ipc.nmbclusters = 1000000

    Would be also fine, because 4 LAN Ports and 4 CPU cores are creating then many queues.
    4 CPU cores * 4 LAN Ports = 16 queues

    Perhaps you will have a look at this site to dig out some tips for squid performance tuning.


Log in to reply