BT Openreach PPOE



  • I have connected BT Openreach fibre box directly into pfSense 2.2.6 box using PPOE.

    The connection is intermittent. If i reboot the pfSense box, sometimes there is a internet connection, sometimes there is no internet connection. If I manually remove and insert the WAN ethernet cable, the internet connection returns. I have also tried replacing the ethernet cable but it didn't make any difference.

    I have created 2x interfaces on pfSense, one is the PPOE connection, the other is the WAN interface. I have tried bridging these interfaces but it didn't make any difference. I have also tried setting MTU to 1492 on both interfaces, but still no effect.

    The only way I can make pfSense and the BT openreach box survive reboots is by setting the WAN interface to 100baseTX <full-duplex>. However, by doing this it creates lots of Errors in on the interface, the PPOE interface shows no errors.

    Can these errors be safely ignored or is there another way to make the connection between BT openreach and pfSense more stable?</full-duplex>



  • Which modem are you using just out of curiosity?

    Are you able to swap interfaces on your pfSense box and see if it continues?  Possible your patch cord is bad?



  • There's no generic issue affecting Openreach supplied FTTC modems and FTTP ONTs.

    As has been suggested, I'd change the patch cord first, then change the interface on your pfSense box if that fails to solve the problems. If you're still having problems, I'd put a switch between the pfSense box and the FTTx device - either a dedicated switch or a dedicated VLAN on a VLAN capable switch.

    It sounds as if your configuration might be wrong. You don't need to bridge anything on pfSense, and you don't need separate PPPoE and WAN interfaces. All you need to do is set the WAN interface's IPv4 configuration type to PPPoE, then configure your ISP's user name and password.

    If your ISP supports IPv6, you likely only need to set IPv6 configuration type to DHCP6, though there are a couple of PPP IPv6 issues in pfSense 2.2.6 that I've produced an interim patch for.

    If the interface on your pfSense box linked to the Openreach device is jumbo frame capable, you could try the RFC 4638 patch, which will allow you to use MTU 1500.

    If you wish to apply both of these patches, you should apply the IPv6 patch first.



  • I have now deleted the other interface. I am using a old VIA EPIA board with a dual PCI riser. The NIC is a Intel PRO/1000 MT Dual port.

    The WAN interface now uses these settings:

    IPv4 Configuration Type: PPoE (+ PPPoE configuration username and password)

    IPv6 Configuration Type: DHCP6

    Block bogon networks: ticked

    So far it has survived one reboot, however it took a few minutes for the internet connection to come alive once pfSense rebooted. If this fails, I will change the patch cable and try another interface.

    I cannot try the MTU 1500 patch as my system is 32-bit.


Log in to reply