Mount cifs share



  • Hi all,
    quick question: how can i mount a share from my NAS (cifs) in pfsense?
    mount -t cifs is not working. mount_smbf not working.
    thx



  • You can't, those components aren't included in 2.2.x and prior versions.

    mount_smbfs is included in 2.3 though, we don't strip quite as much of FreeBSD base components there.



  • thx for the fast answer.



  • Im trying to mount a cifs share on pfsense 2.3.2p1, with no success. I tried for now:

    mount_smbfs -I 20.14.11.12 //dti@dti/webcarlos /mnt/storage
    mount_smbfs: kldload(smbfs): No such file or directory

    or laod the module
    kldload smbfs
    kldload: can't load smbfs: No such file or directory

    I also tried setting up an entry on fstab, and credentials on /.nsmbrc with no success.
    //dti@dti/webcarlos/proxy/      /mnt/storage    smbfs  rw,noauto,-I=20.14.11.12    0      0
    or even
    //dti@dti/webcarlos/proxy/      /mnt/storage    cifs  rw,noauto,-I=20.14.11.12    0      0

    Is it possible on pfsense 2.3.x to mount external storage of any kind? How?



  • I think you can find the module in the upstream FreeBSD releases.

    Though, I'd urge aginst using smb on pfSense, but I'm no expert.



  • Based on my own experiences I wouldn't use mount_smbfs on pfSense, it's a stability hazard at best that you don't want to have on a security critical system.