After latest update pfblocker spits out email log with garbage every 10 mins



  • After last week's firmware update pfsense sends me an email every 10 minutes or so with a message that makes no sense. Any one know what is going on? Message looks like  this:

    Subject:
    Cron root@pfsense/usr/local/bin/php -q /usr/local/www/pfblocker.php cron

    Message:
    X-Cron-Env: <shell= bin="" sh="">X-Cron-Env: <path= etc:="" bin:="" sbin:="" usr="" sbin="">X-Cron-Env: <home= var="" log="">X-Cron-Env: <logname=root>X-Cron-Env: <user=root>No input file specified.

    –-----''
    Thanks!</user=root></logname=root></home=></path=></shell=>/root@pfsense



  • Something to do with pfblocker, BBcan should see it now and can hopefully offer suggestions.


  • Moderator

    Baardrg,

    There is nothing in the pfBlockerNG code that sends out emails.

    • What other packages are installed?

    • What version of pfSense is this from? I'm assuming 2.2.6?

    • Post a screenshot of the widget, so I can see what kind of setup you have.

    • Do you have any errors/warnings in the pfblockerng.log?


  • Moderator

    EDIT:

    Cron root@pfsense/usr/local/bin/php -q /usr/local/www/pfblocker.php cron

    I think you upgraded from 2.1.x to 2.2.x since the path shown above, is for the old pfBlocker version. pfBlocker is not upgradable to pfBlockerNG. You need to delete all reminants of the old pfBlocker. (Rules, Tables, Cron tasks etc…)

    Here is a link to a script that i wrote, to clean this up:
    https://forum.pfsense.org/index.php?topic=88443.msg491279#msg491279/root@pfsense



  • Thank you all for the reply, specially you BBcan177. I ran your script and it looks like it is working. The old pfBlocker never showed up in the menu, it just kept spaming me. Now it's been quiet for an hour or so and normally it would send out a error message every our.
    Thanks a lot! :)


Log in to reply