VM pfSense 2.2.6 no WAN



  • Hello everyone.

    Having an odd issue on first install of pfsense. I installed using my QNAP TVS-EC880 with virtual station which went super smooth. The issue however is that pfsense is not detecting a WAN connection from my modem.

    I have powered cycled the modem and the system, but nothing. My QNAP VS shows the WAN ip connected for that adapter but it doesn't appear to be working.

    Wondering if anyone else has a similar configuration or has a few suggestions.

    Thanks.



  • I wanted to update this post to reflect a method to correct this should anyone else run into a similar issue.

    I visited over at the QNAP forums and posted a similar message to a thread which already talked about running pfSense in a VM.

    mbender71 over at QNAP forums had a similar issue.

    Here is what was done;

    EXCELLENT question as I fought this battle a number of times. The issue is that pfSense is not able to get an IP address via DHCP
    and I believe it has something to do with the MAC address of the pfSense VM versus the MAC address of the physical adapter on the
    NAS. I found only one solution and here is how it goes :

    • attach a desktop/laptop to your cable modem (that's in bridge mode already) and get that working. For me I used my MacBook Pro
      with a thunderbolt to ethernet adapter. The point of this exercise is to get your ISP to recognize the MAC address behind your cable
      modem and lock it in (my ISP only allows one DHCP at a time). PLEASE make sure though that you have your firewall turned on your
      desktop/laptop and perform this operation quick. Leaving a computer jacked to the net directly is dangerous!

    • once you've confirmed your ISP has given you your IP address (i.e. you get get to the net) go ahead and disconnect your computer
      (for safety reasons). what you have now is a very special MAC address. Record the MAC address of the adapter you just used to
      connect your desktop/laptop to your cable modem since that is "golden" with your ISP.

    • open the configuration of your pfSense VM in Virtual Station and begin to edit. What you need to edit is the MAC address of the
      virtual adapter that you will be using for the WAN in your pfSense VM. Copy the registered MAC you just found in the previous step
      into the configuration for the adapter you'll be using in the pfSense VM. For the record, I use the Virtual Ethernet IO (vmnet) for
      both of my pfSense network adapters.

    • connect your cable modem to the designated virtual switch that you have your pfSense WAN network adapter configured to (the
      virtual switch for the WAN connection SHOULD BE configured as EXTERNAL ONLY).

    • fire up your pfSense VM and open the console to watch it boot up. It might ask to configure the WAN/LAN in the CLI, but this time
      pfSense won't hang while it's initializing the WAN as it SHOULD receive its IP during the DHCP portion of it initialization.

    NUTSHELL -> Take a working MAC address that was connected to the cable modem and copy that MAC address (spoofing) in the
    pfSense network adapter that is being used to connect to your cable modem (WAN).

    This is what has worked for me and it's pretty solid. Only once have I had to repeat this crappy procedure when my ISP had a major
    outage for about 6 hours. I DO hope this works for you as I've had one other instance where a local friend had the same problem and
    after giving this solution it worked for him. Good luck!

    Thanks,
    Michael

    Hope this helps anyone else in a case where they are unable to get their WAN to detect.


Log in to reply