Ralink RT5370



  • Hello Guys,

    after i installed pfsense and configured the wlan interface and click apply changes , the System are get an Kernel Panic and reboots now. in the following attached kernel Dump you can see the run Module loads the wrong driver rt3070 not the correct rt5370. What is the prob, pfsense or the wireless nic? Can you give me a list for supported wireless Usb Nics they supported AP-Mode in pfsense?

    ugen4.4: <ralink>at usbus4
    run0: <1.0> on usbus4
    run0: MAC/BBP RT5390 (rev 0x0502), RF RT5370 (MIMO 1T1R), address 00:87:40:92:08:01
    wlan0: Ethernet address: 00:87:40:92:08:01
    <6>wlan0: changing name to 'run0_wlan1'
    run0: firmware RT3071 ver. 0.33 loaded

    kerneldump.txt</ralink>



  • Have you tried pfSense 2.3 alpha testing branch?



  • Can i upgrade from stable to the testing branch from the installed version?



  • Can you give me a list for supported wireless Usb Nics they supported AP-Mode in pfsense?

    pfSense wireless interfaces
    FreeBSD 10.1R hardware support



  • I don't want to see you go that far as to upgrade!. I did have problems with the same RT5572 device on pfSense 2.2.5 and when i tried on 2.3 alpha it worked correctly, albeit at 802.11G speeds.

    If you don't have loads of packages you can easily upgrade. Some packages may need removal and reinstall.

    https://forum.pfsense.org/index.php?topic=103130.0
    So YMMV it worked for me -not him…different device same RT3017.rom



  • unfortunately works the latest alpha neither, the same things is going on when i enable the wlan-Interface. Now i have Tp_link-Wn321g and its the same shit, that is also a prob of pfsense. In the attachments the latest dump, i hope you can see whats the prob.

    dump.txt



  • So i have tested both Usb-Sticks the Ralink and TP-wn321g under Freebsd 10.1-p24 and both sticks are working in the Ap-Mode. The Problem is also definitively PFsense, but why cant i understand have you Ideas?


Log in to reply