CARP backup shows master



  • I recently added another Netgate 2440 and wanted to setup CARP on it for failover.  To the best of my knowledge, I have everything configured correctly but CARP is showing MASTER on both nodes.

    The error I'm getting in the system log on my primary node is as follows:
    php-fpm[76972]: /rc.filter_synchronize: An error code was received while attempting XMLRPC sync with username admin http://192.168.4.2:80 - Code 5: Didn't receive 200 OK from remote server. (HTTP/1.0 301 Moved Permanently)

    From Status (CARP failover on primary)
    LAN@1  10.111.130.143 master  MASTER

    (secondary)
    LAN@1  10.111.130.144 master  MASTER

    192.168.4.1 is the SYNC interface on the primary node
    192.168.4.2 is the SYNC on the secondary and they are directly connected through a cable on igb2

    I have a firewall rule on each server allowing all traffic from the Sync Net everywhere.

    In System/High Avail Sync, Syncrhonize States is set to 192.168.4.2 on the primary node.

    I'm running version 2.2.6 and have auto-submitted a crash report for the bug when prompted.

    What is "moved permanently"?
    Is there a workaround for this bug or another configuration I could try?  Any suggestions would be greatly appreciated.  Thanks in advance.



  • Answering my own question, the "moved permanently" error was caused by protocol mismatches.  I had HTTP enabled on my primary and HTTPS on the backup.
    From:
    https://doc.pfsense.org/index.php/Configuring_pfSense_Hardware_Redundancy_(CARP)

    Before proceeding, set the same admin user password and webConfigurator protocol (e.g. HTTPS) on each cluster node.

    This protocol is set at:  System/Advanced/Admin Access/Protocol


Log in to reply